build failure with "error: ‘class Inkscape::Extension::ParamComboBoxEntry’ has no member named ‘append’"

Bug #927992 reported by Taylor Smolik on 2012-02-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Alex Valavanis

Bug Description

I am in the process of installing Inkscape for Linux, and I can't interpret this error message:

[root@TaylorS inkscape]# make
make all-recursive
make[1]: Entering directory `/home/smolik_tayl/inkscape'
Making all in src
make[2]: Entering directory `/home/smolik_tayl/inkscape/src'
make all-am
make[3]: Entering directory `/home/smolik_tayl/inkscape/src'
  CXX extension/param/enum.o
extension/param/enum.cpp: In member function ‘virtual Gtk::Widget* Inkscape::Extension::ParamComboBox::get_widget(SPDocument*, Inkscape::XML::Node*, sigc::signal<void>*)’:
extension/param/enum.cpp:245:16: error: ‘class Inkscape::Extension::ParamComboBoxEntry’ has no member named ‘append’
make[3]: *** [extension/param/enum.o] Error 1
make[3]: Leaving directory `/home/smolik_tayl/inkscape/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/smolik_tayl/inkscape/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/smolik_tayl/inkscape'
make: *** [all] Error 2

su_v (suv-lp) wrote :

When reporting build failures, please always provide minimal information about your system and build environment.

The reported problem seems to be due a recent change which inadvertently introduced a requirement to having gtkmm <= 2.24 installed, see comment #10
<https://bugs.launchpad.net/inkscape/+bug/367607>

Changed in inkscape:
assignee: nobody → Alex Valavanis (valavanisalex)
status: New → Incomplete
tags: added: build
summary: - error using the make command in terminal to download sourcecode
+ build failure with "error: ‘class
+ Inkscape::Extension::ParamComboBoxEntry’ has no member named ‘append’"
Kris (kris-degussem) wrote :

For windows, part of the solution might be to upgrade tdm-gcc to the latest build. Will check later today (I have those issues with version 4.5.1 of tdm-gcc, vista64 and current trunk revision).

su_v (suv-lp) wrote :

I don't think that upgrading the compiler will help with Windows builds:

According to the readme, KK only updated the GTK+ stack to 2.24.8, while keeping the old version of gtkmm (2.22):
<http://bazaar.launchpad.net/~inkscape.dev/inkscape-devlibs/trunk/view/head:/readme.txt#L35>

Alex Valavanis (valavanisalex) wrote :

No, the compiler version won't help... the build error was caused by me getting rid of the gtkmm top-level header. I don't have a Windows build environment, so I missed the win-specific files.

Alex Valavanis (valavanisalex) wrote :

OK, I have committed a fix in lp:inkscape r10947 for backward compatibility with gtkmm-2.22. I've also added the missing header that should hopefully fix the win32 build. Please let me know if this fixes either/both bugs.

Changed in inkscape:
status: In Progress → Triaged
LucaDC (dicappello) wrote :

Much better, but still getting:

Make error line 289: problem compiling: src/extension/param/enum.cpp: In member function 'virtual Gtk::Widget* Inkscape::Extension::ParamComboBox::get_widget(SPDocument*, Inkscape::XML::Node*, sigc::signal<void>*)':
src/extension/param/enum.cpp:248:16: error: 'class Inkscape::Extension::ParamComboBoxEntry' has no member named 'append'

Alex Valavanis (valavanisalex) wrote :

Oops... I've hopefully fixed it in r10948. Please let me know if there are any other issues.

jazzynico (jazzynico) wrote :

No compile error on Windows XP with 10948. Thanks for the fix!

Changed in inkscape:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers