Error messages from Extensions hidden

Bug #911079 reported by John Smith on 2012-01-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
John Smith
inkscape (Ubuntu)
Low
Unassigned

Bug Description

If an extension has an error or 'additional information' it is shown in a message dialog.
This message is hidden in the dialog on Ubuntu due to the overlay scrollbar and the message window having 0 size.

To reproduce:
1. Start inkscape with empty document
2. Extensions > Modify Path > Perspective
3. A message dialog will appear, but the message is not visible

Ubuntu 11.10 / r10826.

Related branches

John Smith (john-smithi) wrote :

Patch to add a minimum size to the message window

Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
su_v (suv-lp) wrote :

While appreciating the efforts to adapt Inkscape for Ubuntu users, I repeat my concerns mentioned earlier in a related report:
Shouldn't these things also be reported upstream to what actually triggers it (AFAIK ayatana-scrollbar)? I can't image that Inkscape is the only Gtk+ application which doesn't force hard-coded minimal px dimensions on everything. Isn't it Ubuntu and its custom modification of the Gtk+ scroll bars which breaks Inkscape's GUI?

The attachment "911079.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
tags: added: patch-forwarded-upstream
removed: patch
su_v (suv-lp) wrote :

@JazzyNico, @John - while I tended to oppose to fix the overlay-scrollbar issues in Inkscape itself for each of the affected widgets separately, maybe the problem reported here could be addressed in a way that would satisfy other needs as well? I'm thinking of the fact that the initial size of the dialog - especially when used e.g. for debugging purposes in the development process of extensions - is rather small which at some point had triggered a (now reverted) change to always open the dialog in maximized state - see bug #813807.

How difficult would it be to make the dialog remember its last use window size (and position), and adjust (or expand) the size of the text field (scrollwindow) to the restored dialog size (instead of using a hard-coded minimal height)?

John Smith (john-smithi) wrote :

How about if we convert it into a standard dockable Inkscape dialog ?
Dialog can then remain open if the user desires and the window size is remembered if closed and reopened.

su_v (suv-lp) wrote :

> How about if we convert it into a standard dockable Inkscape dialog ?

IMHO it would be better to make the normal extensions dialog (based on the INX file) dockable, but not the one used to provide feedback from the extension script (be it an error or additional information) - to me it makes sense that the error message dialog is modal.

@JazzyNico, what do you think?

su_v (suv-lp) wrote :

Maybe it would be best to commit the initial patch ("Patch to add a minimum size to the message window") for now, and backport it to 0.48.x, so that the message displayed in the dialog is readable again for Ubuntu users (and those with custom gtk themes without minimal constraints for the scroll bar slider length and arrows turned off).

jazzynico (jazzynico) wrote :

> IMHO it would be better to make the normal extensions dialog dockable, but not the one used to provide feedback

Yes, it would be very handy and improve the ui consistency.

> How difficult would it be to make the dialog remember its last use window size.

Don't know. I guess it's just saving the size and position in the prefs file and restore it when needed, but the extension system is a bit specific and may require more work. Will take a look.

John Smith (john-smithi) wrote :

> Maybe it would be best to commit the initial patch ("Patch to add a minimum size to the message window") for now, and backport it to 0.48.x

Yes shall we commit this before 0.48.3 ?

> IMHO it would be better to make the normal extensions dialog dockable,

Issue created as bug #929361

jazzynico (jazzynico) wrote :

> Yes shall we commit this before 0.48.3 ?

Since we have already committed some similar fixes elsewhere, yes.

Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.48.3
status: New → In Progress
Changed in inkscape (Ubuntu):
status: New → Confirmed
Changed in inkscape (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Low
status: In Progress → Triaged
John Smith (john-smithi) wrote :

Initial patch committed to trunk as r10964

John Smith (john-smithi) wrote :

Initial patch committed to 0.48.x branch as 9876

John Smith (john-smithi) on 2012-02-13
Changed in inkscape:
status: In Progress → Fix Committed
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.3-0ubuntu1

---------------
inkscape (0.48.3-0ubuntu1) precise; urgency=low

  * New upstream release (LP: #933188). Fixes several Ubuntu bugs:
    - inkscape fails to build with glib 2.31 (LP: #898538)
    - ctrl c ctrl v of text in edit mode crashes inkscape (LP: #496793)
    - Completely replace lcms1 by lcms2 in Ubuntu (LP: #885324)
    - parameters ending with '\' causes python to bomb (LP: #168417)
    - Extensions with <check> tags fail to load (LP: #668895)
    - ESC doesn't cancel move when using the Node Tool (LP: #788560)
    - unable to edit attributes in Inkscape XML Editor (LP: #884368)
    - Some layers should be visible by default in Layers dialog (LP: #902054)
    - Path Effect List is hidden (LP: #909958)
    - Input Devices > Hardware > Tree of devices is hidden (LP: #910467)
    - Glyphs Font styles are hidden (LP: #911079)
    - Error messages from Extensions hidden (LP: #911079)
    - Messages dialog doesn't work (LP: #911123)
  * Drop 02-add-shebangs-and-fix-permissions.dpatch: Applied upstream.
  * Drop build-dependency on specific libwpd/libwpg version.
 -- Alex Valavanis <email address hidden> Thu, 16 Feb 2012 14:33:40 +0000

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers