Glyphs Font styles are hidden

Bug #910479 reported by John Smith on 2012-01-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
John Smith
inkscape (Ubuntu)
Low
Unassigned

Bug Description

In 'Text > Glyphs…' the list of font styles is hidden and is not expanded when the window is resized in Ubuntu due to liboverlay-scrollbar.

Ubuntu 11.10

John Smith (john-smithi) wrote :

Patch to set a minimum size of the font style list.

Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
jazzynico (jazzynico) wrote :

I haven't tried with 11.10 yet, but with 11.04 (classic Gnome, no Unity desktop), the font list is smaller with the your patch. I guess the minimum size is what is actually used by the widget here, but the spec is not very clear to me [1]:

"Sets the minimum size of a widget; that is, the widget's size request will be width by height. You can use this function to force a widget to be either larger or smaller than it normally would be. "

Minimum, but can force to be smaller than normally would be? Hugh.

If it's a normal behavior, I'd use a slightly higher value (visually, it looks like a 150 on my computer).

[1] http://developer.gnome.org/gtk/2.24/GtkWidget.html#gtk-widget-set-size-request

jazzynico (jazzynico) wrote :

Confirmed on Ubuntu 11.10 (Unity), Inkscape 0.48.2.

Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.48.3
status: New → In Progress
Changed in inkscape (Ubuntu):
status: New → Confirmed

The attachment "910479.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
tags: added: patch-forwarded-upstream
removed: patch
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
jazzynico (jazzynico) wrote :

Committed in the trunk (with a minimum size set to 150), revision 10818.
Backport in progress.

jazzynico (jazzynico) wrote :
jazzynico (jazzynico) wrote :

Committed in the 0.48.x branch, revision 9845.
Thanks John!

Changed in inkscape:
status: In Progress → Fix Committed
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
Vibhav Pant (vibhavp) wrote :

Attahced the Debdiff

Daniel Holbach (dholbach) wrote :

The last attachment seems not to be meant to have been on this bug report.

Daniel Holbach (dholbach) wrote :

With 0.48.3.1-0ubuntu1 in Ubuntu precise, I think we can close this bug.

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers