Preferences > 'System Info' window is very small

Bug #910463 reported by John Smith on 2012-01-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
John Smith

Bug Description

File > Inkscape Preferences > Misc > 'System Info' window only shows about 2 lines of 'System Info'.

Typically there is quite a bit of 'System Info' data and it is hard to read in such a small window.
The Misc panel has lot of space, so this window can be expanded easily.

Windows 7.

John Smith (john-smithi) wrote :

Patch to increase size to about 8-10 lines.

Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
jazzynico (jazzynico) wrote :

Confirmed on Ubuntu 11.10 (Unity), Inkscape 0.48.2. The widget's size 0.

tags: added: preferences ui
Changed in inkscape:
importance: Undecided → Low
milestone: none → 0.48.3
status: New → In Progress
jazzynico (jazzynico) wrote :

Committed in the trunk, revision 10818.
Backport in progress.

jazzynico (jazzynico) wrote :

Committed in the 0.48.x branch, revision 9845.
Thanks John!

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

Couldn't we change the layout, making 'System info' a section header or title _above_ the info field, and use the full width of the panel for the text widget displaying the system info below? Or at least align it with the top of the text widget?

su_v (suv-lp) wrote :

Quick mockup for 'Preferences > Misc > System info'

su_v (suv-lp) wrote :

Mockup redone using 'Ambiance' theme

John Smith (john-smithi) wrote :

Agreed, that looks like a good idea ~suv. Heres a patch for that.

Or, we could even give 'System Info' its only page in the left panel.

jazzynico (jazzynico) wrote :

@John - I'm currently working on the preferences, and will add your modifications shortly.
What about using a different entry for each subfield in the system infos? It would possibly look a bit cleaner.

jazzynico (jazzynico) wrote :

Mockup for the system tab attached.
(The title and icon are still work in progress.)

su_v (suv-lp) wrote :

Another field that might be useful and could be easily added to this new 'System' pane:
Explicit full path to the preferences file, including the file name (see also bug #500961)

<off-topic>
A button to optionally reset the preferences (as mentioned in bug #500961) is a different (and AFAIU more complex) issue than simply displaying information, and probably would be best combined with a solution addressing requests which ask for other aspects of 'resetting the prefs' - see bug #784811 (reset only certain or broken settings) and bug #911700 (auto-recreate default prefs file in case of external mishap).
</off-topic>

John Smith (john-smithi) wrote :

Another mockup based on JazzyNico's ideas and added the new fields suggested in bug #500961.

I suggest we remove the follow fields that are not used or are directly derived from other fields
* System Config: doesn't seem to be used anywhere in Inkscape.
* Pixmap: Derived from data - do anyone need to directly access this ?
* UI: Derived from data - do anyone need to directly access this ?

su_v (suv-lp) wrote :

Extensions are loaded from $XDG_CONFIG_HOME/inkscape/extensions as well - listing only the shared location for extensions - same as `inkscape -x` - might give casual users the wrong impression?
Maybe add an item "inkscape user configuration directory" (or 'inkscape user profile', or whatever makes more sense), pointing to $XDG_HOME_CONFIG/inkscape', in addition to the name of the preferences file, for those wanting to install local resources?

John Smith (john-smithi) wrote :

Patch for the above (#12), including the corrected 'User config' path and the 'User Extensions' path.

John Smith (john-smithi) wrote :

Is this worth committing for 0.48.3 ?

jazzynico (jazzynico) wrote :

Minor versions are bugfix only, and should not add new features or new strings (so that we don't need to update the translation files). But feel free to update the trunk.

John Smith (john-smithi) wrote :

Thanks JazzyNico.
Commited to trunk as r10973.

Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers