Floating a docked dialog causes lose of mouse focus & cant click any buttons in main window

Bug #907157 reported by John Smith on 2011-12-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
John Smith
Nominated for 0.48.x by Alex Valavanis

Bug Description

1. Start Inkscape, dock the layers dialog.
2. Drag layers dialog to float.
3. Error is thrown : (inkscape:21491): Gtk-CRITICAL **: IA__gtk_grab_remove: assertion `widget != NULL' failed
4. Now the document has lost mouse focus, you cannot click on any buttons in the main window/toolbars

Ubuntu 11.10 / Gnome 3.2.1 / Inkscape 0.48+dev (rev 10788)

Tags: ui Edit Tag help
John Smith (john-smithi) wrote :
su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48+devel r10788
on OS X Lion 10.7.2, X11/XQuartz 2.6.3 (xorg-server 1.10.3)

$ gcc --version
i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.1.00)
$ port installed glib2 glibmm gtk2 gtkmm
The following ports are currently installed:
  glib2 @2.30.2_2 (active)
  glibmm @2.28.2_0 (active)
  gtk2 @2.24.8_1+x11 (active)
  gtkmm @2.24.2_0 (active)

Changed in inkscape:
importance: Undecided → Medium
Alex Valavanis (valavanisalex) wrote :

Confirmed:

* Ubuntu 11.10
* GTK+2 2.24.6-0ubuntu5

@John - Any ideas when this first started?

Changed in inkscape:
status: New → Triaged
John Smith (john-smithi) wrote :

Noticed it started happening within the last week or so.

Alex Valavanis (valavanisalex) wrote :

OK, I just tried a build of the 0.48.x branch, and I tried the official pre-build Ubuntu binary package... same problem exists in both cases! I wonder why we haven't noticed this bug previously?

@John - I also find that when I try to close any floating dialog, I get a whole load of errors:

Gtk-CRITICAL **: IA__gtk_widget_event: assertion `WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

Do you have the same experience?

John Smith (john-smithi) wrote :

Alex, yes i see the same errors when closing a floating dialog that was just drag floated - the cause appears to be the above error.
Dialogs that were previously in the floating state when opened are not affected.

BTW the patch above fixes this error as well.

Alex Valavanis (valavanisalex) wrote :

Hi John,

Thanks for testing, and thanks for the patch! Before I go ahead and apply it, I'll have a quick poke around to see if the bug was already fixed in an upstream version.

Alex Valavanis (valavanisalex) wrote :

Fix committed in trunk r10800. I still haven't fully figured out why this started happening. The bug also occurs in the test-dock application provided with upstream GDL 2.30 when I apply our minimal patch, but disappears in GDL >= 2.91.2.

Therefore, I guess something fixed the problem in the upstream GDL transition to GTK+ 3 compatibility... so there's probably no need to forward the patch upstream.

Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
milestone: none → 0.49
status: Triaged → Fix Committed
tags: added: backport-proposed
Alex Valavanis (valavanisalex) wrote :

The issue still affects the 0.48.x branch. I'll try a backport tomorrow.

John Smith (john-smithi) wrote :

Is this worth targeting for 0.48.3 ?
The fix is pretty simple and enables Ubuntu users to float/dock dialogs.

Alex Valavanis (valavanisalex) wrote :

Oops... yeah, definitely. I forgot to backport it. I'm back home tomorrow, so hopefully I'll be able to do it then if no one beats me to it.

Alex Valavanis (valavanisalex) wrote :

Finally backported this to lp:inkscape/0.48.x r9852

Changed in inkscape:
milestone: 0.49 → 0.48.3
su_v (suv-lp) on 2012-01-28
tags: removed: backport-proposed
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers