Bend LPE incorrect on groups with objects which have a preserved transformation.

Bug #898797 reported by Spencer Stirling on 2011-12-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Adonis Papaderos

Bug Description

The bend effect doesn't play nicely with grouped objects in 0.48.2. I have to specifically ungroup and then regroup the objects before I can bend them correctly (even if I just barely created the group). I'm guessing that the "ungroup" option resets something so that bend works correctly.

Steps to reproduce:

draw two horizontal paths (one above the other) using the pencil tool
group them
try to bend them... they'll go wild

Workaround:

draw two horizontal paths (one above the other) using the pencil tool
group them
ungroup them
group them AGAIN
bend works properly

su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48.2 and 0.48+devel r10754 on Mac OS X 10.5.8 (i386)

1) Could you please attach a sample SVG file with a group that "goes wild" as well as with one that works ok?
2) With regard to the steps of the workaround: did you reapply the 'Bend' path effect after grouping the two paths again?

tags: added: groups livepatheffects
su_v (suv-lp) on 2011-12-01
Changed in inkscape:
status: New → Incomplete
Spencer Stirling (stirling) wrote :

In a freshly-opened file it seems to work correctly, so I see your confusion. I have attached a file where, if you follow the previous instructions (create a new new group object somewhere...), the newly-grouped objects "go wild" when you bend them. Debian Linux squeeze 64-bit, Inkscape 0.48.2 compiled and installed from vanilla source

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48.2 and 0.48+devel r10754 on Mac OS X 10.5.8 (i386):

A - with attached sample file

B - new paths inside transformed groups (or layers):
1) draw two rectangles some distance apart and group them
2) move the group e.g. further down
3) enter the group (with 'Ctrl+Enter')
4) draw two paths (inside the moved group) and group them
5) apply path effect and bend

C - use preserved transforms (preferences)
1) change the preferences to always use preserved transforms
2) draw two paths and group them
3) apply path effect and bend

Workaround for A - add a new layer & work on the new layer, or the same as B
Workaround for B - nudge the new paths with the arrow keys (e.g. a step up and one down again) before grouping them
No workaround for C - (however, the default setting is 'Optimized transforms').

What triggered it in your example:
At some point the page had been resized, which added a 'transform' attribute to the top-level layer (that's normal and not a bug by itself). When new paths are created after having resized the document page, initially they have coordinates as shown in the GUI and a preserved 'transform' attribute to compensate the 'transform' of the parent layer. Once the new paths have been edited (nudge, group/ungroup, etc.), the explicit transformation is removed and optimized into the path data. After that, the path effect on the group works ok.

tags: added: transformations
Changed in inkscape:
importance: Undecided → Medium
status: Incomplete → Confirmed
summary: - Inkscape live path effects bend behaves strangely with grouped objects
+ Bend LPE incorrect on groups with objects which have a preserved
+ transformation.
su_v (suv-lp) wrote :

To clarify: B and C are steps how to reproduce it in _new_ documents.

su_v (suv-lp) wrote :

Correction for C:

C - use preserved transforms (preferences)
1) change the preferences to always use preserved transforms
2) draw two paths, move them
3) group the moved paths
4) apply path effect and bend

(don't forget to revert the preferences setting when done with testing).

su_v (suv-lp) wrote :

Also reproduced with Inkscape 0.47 where path effects for groups was initially implemented:
<http://wiki.inkscape.org/wiki/index.php/Release_notes/0.47#Path_Effects_for_groups>

Changed in inkscape:
status: Confirmed → Triaged
Martin Owens (doctormo) wrote :

Merged in patch, see r12539.

Changed in inkscape:
status: Triaged → Fix Committed
su_v (suv-lp) on 2013-09-19
Changed in inkscape:
milestone: none → 0.49
assignee: nobody → Adonis Papaderos (ado-papas)
su_v (suv-lp) wrote :

Attached backport of r12539 to the stable branch tested successfully with 0.48.x r9963 on OS X 10.7.5.

Please review (the revision didn't merge without a text conflict into 0.48.x).

tags: added: backport-proposed
jazzynico (jazzynico) wrote :

Backport patch tested successfully on Windows XP, 0.48.x branch revision 9663.

su_v (suv-lp) wrote :

Backport committed to lp:inkscape/0.48.x in revision 9965

Changed in inkscape:
milestone: 0.49 → 0.48.5
Kris (kris-degussem) on 2013-12-11
tags: removed: backport-proposed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments