Inconsistent/Broken Copy-Paste in Fedora 16

Bug #897709 reported by Matt Reid on 2011-11-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
abhilash

Bug Description

Copy-paste is basically nonfunctional on my Lenovo T520 running Fedora 16 x64. I'm running inkscape-0.48.1-9.fc16.x86_64, but have tried inkscape-0.48.1-4 and inkscape-0.48.2-1 recompiled for my Fedora version and had the same issue. This is in spite of inkscape running fine off one of those official Fedora 15 flash drives (which I believe was inkscape 0.48.1), and a RHEL 6.1 Workstation. A VM running RHEL 6.2 server on top of F16 also does not exhibit any issues, which was inkscape 0.47.

For all intents and purposes, copy-paste is broken for me. I can copy things to the clipboard, which seems to be putting things in the clipboard (checked out the drag and drop tool, and saw stuff going in), and the paste menu option lights up. However, when actually trying to paste, most of the time I get nothing, sometimes I get 2 - 4 pastes before it stops pasting. Once it doesn't paste when I tell it to, I haven't been able to make it paste again without doing another copy. I can't make it paste anything between instances of inkscape.

Steps to reproduce:
1. Open inkscape
2. Create a few shapes/text
3. Select something and copy using menu or keyboard
4. Attempt to paste a few times, may get something, probably will get nothing
5. Repeat steps 3 and 4 and get different results

This happens in new files, in my saved files, everything as far as I can tell.

I'm happy to provide any additional information.

Edit: Not sure if there's a way to link these or anything, but another user reported what sounds like maybe the same issue over on Bugzilla - https://bugzilla.redhat.com/show_bug.cgi?id=756604

su_v (suv-lp) on 2011-11-29
tags: added: clipboard
removed: copy-paste fedora
su_v (suv-lp) wrote :

Do you happen to have a download or clipboard manager running in the background monitoring the clipboard and possibly interfering with Inkscape and its usage of the system clipboard? Also, other applications (e.g. NetBeans Java IDE) have been reported to interfere with Inkscape's copy&paste, as well as desktops environments like Xfce.

Possibly related reports:
Bug #312286 “Copy+Paste stopped working”
<https://bugs.launchpad.net/inkscape/+bug/312286>
Bug #418242 “Incorrect call to output plugins (with persistent error message) on copy”
<https://bugs.launchpad.net/inkscape/+bug/418242>

Matt Reid (zeeboreid) wrote :

I'm running Gnome Shell with native window placement, user themes, and remove accessibility icon extensions. I haven't consciously installed a clipboard/download manager, and definitely don't have NetBeans.

Forgot to mention that CTRL-D works perfectly, which is why I only noticed this trying to copy-paste between inkscape instances.

I've attached the output of ps -A in case you're curious (lots of processes, so I don't want to clutter this up if you don't care).

Matt Reid (zeeboreid) on 2011-11-29
description: updated
su_v (suv-lp) wrote :

> 1852 ? 00:00:10 gpasted

Could you check whether on the other tested systems, you have gpasted running as well?

Possibly related:
gpasted baffles copy/paste within libreoffice
<https://bugzilla.redhat.com/show_bug.cgi?id=742970>

I can confirm that clipboard manager extension affects copy/paste from inkscape and libreoffice negatively.
Disabling it fixes the problem, so it's not really an inkscape bug but gnome's clipboard management.
In the bug report that ~suv linked there's a comment stating that removing the extension doesn't uninstall gpasted, so you probably installed the extension and uninstalled it later but gpasted was kept (running).
I'd try this: re-install the clipboard extension, de-activate the clipboard inspection (from extension's options, to kill the daemon), de-activate the extension and try again.
If that fixes the issue we can confirm that it's not an inkscape bug.

Matt Reid (zeeboreid) wrote :

You guys are absolutely correct, gpasted is the source of my problems. I installed all of the gnome shell extensions, and did enable the gpaste one once, but almost immediately disabled it again so I thought it wasn't doing anything (wrongly).

I tried what you said Guillermo, (reenabling the extension, telling it to not track clipboard changes, and then turning the extension back off), but that still left gpasted running and it still ran at login. Disabling it with gnome-session-properties has solved my issue. Also confirmed that the other systems I talked about above without the issue did not have gpasted running, and on my F16 install I could paste fine after killing gpasted.

It'd be nice if gnome-shell-extension-gpaste cleaned up after itself better...

I'll carry this over to the RH BZ, maybe they ran into the same thing.

Thanks for your help!

Closed as invalid (not an Inkscape's bug).
Thanks Matt for your feedback. Please use this information to complete the bug report in RedHat's bug tracker, so all affected applications benefit with a future fix.

Changed in inkscape:
status: New → Invalid
mairin (mairin) wrote :

Thanks for helping track this down, folks; it's greatly appreciated. I <3 Inkscape!!

Gabriel Bauman (gabrielbauman) wrote :

A possible fix has been pushed to Fedora's updates-testing repository. See https://bugzilla.redhat.com/show_bug.cgi?id=742763 :)

Matt Reid (zeeboreid) wrote :

Just installed the 2.0 version of GPaste and everything seems fine with Inkscape again.

Changed in inkscape:
assignee: nobody → abhilash (abhilashdesai123)
status: Invalid → In Progress
Changed in inkscape:
status: In Progress → Confirmed
abhilash (abhilashdesai123) wrote :
abhilash (abhilashdesai123) wrote :

Exceptions are to be removed to avoid aggressive response over paste

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.