Grid: When units set to ft, Spacing X & Y is ignored

Bug #885500 reported by Bob Silvern on 2011-11-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Johan Engelen

Bug Description

Created new document, landscape, units: Ft, size: 90x30
Set grid units to Ft. Grid is extremely fine. Trying to get 10x10 Ft grid.
Setting Spacing X and Spacing Y arbitrarily high has no effect.

Version 0.48.1.
Win XP SP3

su_v (suv-lp) on 2011-11-03
tags: added: grids
removed: grid spacing
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48.1, 0.48.2 and 0.48+devel r10710 on Mac OS X 10.5.8 (i386):

Works when setting grid units to 'in' and spacing to 120x120 (equals 10x10 ft) - see attached sample file with two grids defined - but not when using 'ft' as units for the grid.

Note: when switching grid units from 'ft' to 'in', the update of the spacing needs to be triggered manually by clicking on one of the up/down arrows of the spinboxes (similar to bug #561503 when changing the offset of the origin).

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) wrote :

<off-topic>
> new document, landscape, units: Ft, size: 90x30
> Set grid units to Ft. Trying to get 10x10 Ft grid.

Not sure what exactly the expectation or use case is with such a huge page size? Depending on your monitor size, you barely will be able to view the whole page even if zoomed out to Inkscape's max zoom level (at 1 % zoom), let alone print it or export the page to bitmap easily (at default dpi) without hitting memory limits (depending on drawing content; even with 27 simple (solid filled) 10x10 ft squares and no filter effects, export at default 90dpi takes minutes, and the resulting file is 11.8 MB).

At which zoom level (and level of detail) are you planning to work, and why do you need such a huge page size (corresponds to 97'200.00 x 32'400.00 px, or 27.43 x 9.14 m)? You might consider drawing at scale like you would on paper, instead of trying to draw in "real" units at a scale of 1:1.
</off-topic>

I'm a newbie with Inkscape and have just started drawing a house floor plan.
Normally I would have used a scale larger than 1:1, but when I saw the
option to specify the page size and the grid in feet, I saw no harm in
working at 1:1. It didn't occur to me that printing would be a problem.

Still, I think it would be a good idea to make the grid behave as expected
in such cases or to provide an error message when outlandish values are
specified.

Thanks for the amazingly fast response!

Bob

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of ~suv
Sent: Wednesday, November 02, 2011 9:32 PM
To: <email address hidden>
Subject: [Bug 885500] Re: Grid: When units set to ft, Spacing X & Y is
ignored

<off-topic>
> new document, landscape, units: Ft, size: 90x30
> Set grid units to Ft. Trying to get 10x10 Ft grid.

Not sure what exactly the expectation or use case is with such a huge
page size? Depending on your monitor size, you barely will be able to
view the whole page even if zoomed out to Inkscape's max zoom level (at
1 % zoom), let alone print it or export the page to bitmap easily (at
default dpi) without hitting memory limits (depending on drawing
content; even with 27 simple (solid filled) 10x10 ft squares and no
filter effects, export at default 90dpi takes minutes, and the resulting
file is 11.8 MB).

At which zoom level (and level of detail) are you planning to work, and why
do you need such a huge page size (corresponds to 97'200.00 x 32'400.00 px,
or 27.43 x 9.14 m)? You might consider drawing at scale like you would on
paper, instead of trying to draw in "real" units at a scale of 1:1.
</off-topic>

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/885500

Title:
  Grid: When units set to ft, Spacing X & Y is ignored

Status in Inkscape: A Vector Drawing Tool:
  Confirmed

Bug description:
  Created new document, landscape, units: Ft, size: 90x30
  Set grid units to Ft. Grid is extremely fine. Trying to get 10x10 Ft grid.
  Setting Spacing X and Spacing Y arbitrarily high has no effect.

  Version 0.48.1.
  Win XP SP3

To manage notifications about this bug go to:
https://bugs.launchpad.net/inkscape/+bug/885500/+subscriptions

Johan Engelen (johanengelen) wrote :

fixed. It could be that you notice more bugs when using feet, since not that many people use it...

Changed in inkscape:
status: Confirmed → Fix Committed
assignee: nobody → Johan Engelen (johanengelen)
milestone: none → 0.48.3
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers