One Scaling arrow missing after opening EPS file

Bug #884125 reported by rickmastfan67 on 2011-10-31
This bug report is a duplicate of:  Bug #360158: Control points not drawn at (0,0). Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

0.48.2 r9819
GPL Ghostscript 9.02
Windows 7 x64 RTM

Steps to reproduce:
1. Locate an EPS file on your computer to open. (Use the following from this site for this bug to happen: http://www.seeklogo.com/kdka-tv-logo-77738.html)
2. Right click on it (once extracted after downloading it) and tell it to open it in Inkscape (unless EPS files have already been associated with Inkscape to open in it directly, then just double click on it)
3. Once the import screen for the EPS file shows up, just hit OK. (This problem happens with any settings, so no specific settings are needed for this bug)
4. Once the image has been displayed in Inkscape. left click on the image to display the scaling arrows.

What happens:
All but 1 of the scaling arrows are displayed.

What should happen:
All 8 scaling arrows should be displayed.

The missing scaling arrow is the bottom left one.

There is a minor work around for this when it does happen:
1. Left click on the image you imported and drag the image and then let go.
2. Once you have done that (all 8 scaling arrows are now displayed), click the undo button (or Ctrl+Z) to move the image back to it's original location.
3. Now you have the image back where it started and have all 8 scaling arrows available for use.

This problem also shows up in 0.48.1-2.

NOTE: This doesn't happen with all EPS files. I've only had it happen (so far) with 2 different files when opening them, but it happens all the time with them. So, the files are somehow triggering a very rare bug with the scaling arrows in Inkscape.

description: updated
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48.2 on Mac OS X 10.5.8 (i386)
Not reproduced with Inkscape 0.48+devel r10708

Only affects the transformation handle of objects at the origin (0,0) i.e. the lower left page corner.

Linking as duplicate to Bug #360158 in Inkscape: “Control points not drawn at (0,0)” - Please add a comment here and revert the duplicate status if you don't agree and think these are different issues.

tags: added: selection ui
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers