Spray Single Path Mode includes original object

Bug #879058 reported by vincent on 2011-10-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico

Bug Description

Version 0.48.2 r9819 , tool Spray Single Path Mode ,OS: windows 7 64 bits
in my opinion it has 2 bugs
1 although it is "Single Path Mode" it should not alter the original Path it should make a second Path where it makes its Single Path ting and leave the original as is
2 if the path is a straight line (freehand drawing, double click for line mode or diagram connector) Spray Single Path Mode will most certainly erase previous copies of the original line(that Spray Single Path Mode created) in the Path if in reach of the spray area or last copy created.
I see two possible causes for this
1 Spray Single Path Mode ignores a point(or 2) of the surrounding copies at some point to make its merging thing(?man I,m clueless) since lines only have 2 they disappear.
2 it cant close(connect start and end point) properly and has an filed space=null or line over line problems.

su_v (suv-lp) on 2011-10-20
tags: added: boolops spray
su_v (suv-lp) wrote :

> 1 although it is "Single Path Mode" it should not alter
> the original Path it should make a second Path where
> it makes its Single Path ting and leave the original as is

Not reproduce in Inkscape 0.48.2: in the single path (union) mode, the original object is untouched (the unioned path does though include a copy of the original object stacked on top of it). If the the "sprayed" path itself is deleted, the original object gets visible again (it is not deleted, unless it was part of the selection which was deleted).

> 2 if the path is a straight line (…) will most certainly erase previous copies (…)

Reproduced in Inkscape 0.48.2: as far as I understand this is the same underlying issue as (i.e. a duplicate of)
 Bug #166009 “overlapping two-node straigh line paths disappear on union”
 <https://bugs.launchpad.net/inkscape/+bug/166009>
A path operations like 'Union' does work on the area of 'unioned' objects, straight lines do not have an area and are discarded.
Workaround for the spray tool (as is for unioning the outlines of straight lines): select the original line and convert the stroke to path (menu 'Path > Stroke to Path), before using it as original object in the spray tool.

jazzynico (jazzynico) wrote :

Adding a copy of the original object as the first element of the single path is a bit confusing. Maybe the spray tool should leave the original outside the single path, an start the path with the first sprayed object.

jazzynico (jazzynico) wrote :

Leaving apart the union issue (reported in Bug #166009), the fact that the single path mode reuse a copy of the original path is somewhat annoying, and can't be considered a desired feature. I'd rather see the spray path start with the first sprayed object.

summary: - Spray Single Path Mode erases previous lines
+ Spray Single Path Mode includes original object
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) wrote :

> the fact that the single path mode reuse a copy of the
> original path is somewhat annoying and can't be
> considered a desired feature. I'd rather see the
> spray path start with the first sprayed object.

To be considered: if the original is not kept, one cannot reuse the original for a second or third round of spraying without taking care by duplicating it first, or storing the original on a hidden layer.

su_v (suv-lp) wrote :

sorry, ignore my last comment:
> I'd rather see the spray path start with the first sprayed object
full ACK

/me wished launchpad allowed to edit comments ;)

jazzynico (jazzynico) on 2013-08-19
Changed in inkscape:
status: Confirmed → Triaged
su_v (suv-lp) on 2014-01-26
tags: added: easy-fix
su_v (suv-lp) on 2014-01-31
tags: removed: easy-fix
jazzynico (jazzynico) wrote :

Patch tested on Windows XP, Inkscape trunk revision 12994.

Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
milestone: none → 0.91
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

Fixed in the trunk, revision 13011.

Changed in inkscape:
status: In Progress → Fix Committed
tags: added: backport-proposed
jazzynico (jazzynico) wrote :

Not completely fixed (console message due to NULL object added to the selection).
Patch in progress.

jazzynico (jazzynico) wrote :

Console messages fixed revision 13031 (nice palindromic number...).

Krzysztof Kosinski (tweenk) wrote :

Fixed in stable r10014.

Changed in inkscape:
milestone: 0.91 → 0.48.5
tags: removed: backport-proposed
Changed in inkscape:
importance: Low → Medium
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers