Regression (r10675): snapping to node targets fails

Bug #874213 reported by su_v on 2011-10-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Diederik van Lierop

Bug Description

Steps to reproduce:
1) launch inkscape with default new prefs
2) open attached drawing
3) try to snap e.g. a guide to one of cusp nodes of the 'cross' within the dotted frame

Expected result:
The guide can be snapped to any of the cusp nodes

Actual result:
No snap targets are detected

Also affects all path tools and the node tool, affects other node snap targets (path, intersection, smooth, midpoint of line).
Snapping nodes to other snap targets (grid, guides, midpoint, rotation center) works correctly.

I fail to consistently reproduce this in a new drawing - at best the node snapping behavior in r10675 seems erratic to me (it does not seem related to the known issues with path intersections). The objects in the attached document originate (via copy & paste) from a custom 'icons.svg' file (WIP).

Workaround: apparently, with this document, snapping to node targets works if changing
'Document properties > Snap to Objects' to '[x] Always snap'
(which I'd rather not do ;) )

Not reproduced with Inkscape 0.48+devel r10672
Reproduced with Inkscape 0.48+devel r10675
on Mac OS X 10.5.8 (i386)

su_v (suv-lp) wrote :
su_v (suv-lp) wrote :

@Diederik - could you take a look?

Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)
LucaDC (dicappello) wrote :

I tried starting from a new document and noticed that snapping occurs only for Y near the center of the page: draw a small path in the center of the page and you get snapping; the farther you move it from the center (in Y direction), less and less cusps are snapped to. It also seems related to the object dimension: something to do with snapping only inside a not correctly positioned bounding box?
I hope this helps.

su_v (suv-lp) wrote :

@LucaDC - I take that as confirmation that you notice the same regression? ;)

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed

This has been fixed in rev. 10677.

I really should have noticed this myself, sorry for that :-(

Changed in inkscape:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers