Pencil (bezier) - Snap page border - Snap Path must be acttive too

Bug #850982 reported by pRototype on 2011-09-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Diederik van Lierop

Bug Description

OS: Both XP and W7 affected
Inkscape 0.48+devel r10627

I don't know is this is by design, but I share it anyway.

When using the "Draw bezier curves and straight lines" tool (I call it "pen tool" hereafter) the mouse pointer won't snap to page border when only "Snap to the page border" is active.
I also have to activate "Snap to paths" to make it happens.

I would expect the mouse pointer to snap to the page border when the "Snap to the page border" is active, regarless if I move an object with snap points activated or uses some painting tool.

Well, Spray box and Sculpting tool is of course an exeption. Any snapping effect on those would not have any purpose..

su_v (suv-lp) on 2011-09-15
tags: added: snapping
Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)

Attachment deleted because it wasn't related

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) on 2011-09-17
Changed in inkscape:
importance: Undecided → Low

Fixed as of rev. #10635. Thanks for reporting!

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) wrote :

Setting to 'Fix Released' [1] since this works as expected in Inkscape 0.48.2:

Default prefs, new document, activate 'Snap page borders' and draw a line with the pencil or pen tool: (node) snapping occurs for page corners as well as page borders without activating any additional snap options.

Please revert to 'Fix Committed' if you think this change of bag status was done in error.

[1] In accordance with <http://wiki.inkscape.org/wiki/index.php/Bug_management#Bug_status>

Changed in inkscape:
status: Fix Committed → Fix Released
su_v (suv-lp) wrote :

Failed to notice earlier:

Revision 10635 and later: snapping to path intersections now always snaps to path as well - in r10634, snapping to path intersections did not snap to path (unless the separate toggle was activated as well).

How could you possibly have missed such an issue ;-) ?

Fixed as of rev. #10639;

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers