Dynamic offset ungroup issue

Bug #844909 reported by Kirk Cooper on 2011-09-08
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Mc

Bug Description

I selected a few layers of image and group them. Then I move the "group selection" away from the work page. And then I select object and right click "ungroup" and one of the layers returns to the workpage. I will send file .

All you need to do is move selection away from work page and click ungroup ( I have noticed sometimes you have to click more than once for it to work) and the white layer should move to the workpage and the red thing will remain where you moved selection.

Kirk Cooper (enoted) wrote :
su_v (suv-lp) on 2011-09-08
tags: added: groups transformations
su_v (suv-lp) wrote :

Similar to bug #239430 “linked offset ungroup issue”, the dynamic offset inside the group which has been transformed does not inherit the parent transform of the group when ungrouped, instead it reverts to the untransformed position before the group was transformed.

Steps to reproduce:
1) open a new document (default preferences)
2) draw a path (e.g. a triangle with the pen/bezier tool)
3) duplicate the path (Ctrl+D)
4) apply 'Path > Dynamic Offset' (Ctrl+J) to the duplicate
5) select all (Ctrl+A) and group it (Ctrl+G)
6) move (or flip) the group
7) ungroup it (Ctrl+U)

Expected result:
After ungrouping the two objects stay in place.

Actual result:
After ungrouping, the dynamic path reverts back to the position before the group was moved (flipped).

Reproduced with Inkscape 0.48.1, 0.48.2 and 0.48+devel r10624 on Mac OS X 10.5.8 (i386).

summary: - Ungroup selection layers moves all over the place
+ Dynamic offset ungroup issue
Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
su_v (suv-lp) wrote :

typo:
- After ungrouping, the dynamic path reverts back to the position before the group was moved (flipped).
+ After ungrouping, the dynamic offset reverts back to the position before the group was moved (or flipped).

Mc (mc...) wrote :

fixed in r 14305

Changed in inkscape:
assignee: nobody → Mc (mc...)
status: Confirmed → Fix Committed
su_v (suv-lp) on 2015-08-16
Changed in inkscape:
milestone: none → 0.92
su_v (suv-lp) on 2015-09-30
tags: added: backport-proposed
su_v (suv-lp) wrote :

Fix backported to 0.91.x in rev 13832.

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments