Stroke width doesn't respect viewBox anymore

Bug #843856 reported by Dusan Maliarik on 2011-09-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Krzysztof Kosinski

Bug Description

We upgraded inkscape to trunk (to solve https://bugs.launchpad.net/inkscape/+bug/165780), but now there is some regression bug regarding stroke-width. It doesn't seem to respect viewBox anymore. Compare the rendering output of attached file between:

before: Inkscape 0.48.1 r9760 (Apr 21 2011)
after: Inkscape 0.48+devel r10610 (Sep 2 2011)

Dusan Maliarik (dusan-maliarik) wrote :
su_v (suv-lp) on 2011-09-07
tags: added: renderer-cairo
su_v (suv-lp) wrote :

Could you be more specific about the differences you see when exporting to bitmap?

I tested exporting to bitmap (90dpi, default) with Inkscape 0.48.1, 0.48.2 and 0.48+devel r10624 on Mac OS X 10.5.8 (i386) and can't detect a noticeable difference at first sight. There are probably too many details in the drawing you are familiar with, but may not be obvious for someone not having manually edited the file (or used a third-party application for editing - since Inkscape does not create a viewBox attribute by itself).

Dusan Maliarik (dusan-maliarik) wrote :

It's about the strokes on the text. No matter how you adjust SVG width, height and viewBox, the stroke width is the same. It should scale along with the rest of the graphic. In particular, with previous version (>= r9760 && < r10610) it was thicker (correct).

su_v (suv-lp) wrote :

It appears that revision 10610 is the only devel build you tested - it was affected by a regression which didn't render stroked text properly. The issue (stroke width on text was independent of zoom) was fixed in r10620 and r10622.

See also:
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/37212/focus=37220>

tags: added: regression text
Changed in inkscape:
importance: Undecided → Medium
status: New → Fix Released
assignee: nobody → Krzysztof Kosinski (tweenk)
Dusan Maliarik (dusan-maliarik) wrote :

I just noticed, thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments