Use Measurment tool like on-canvas informations for snapping too

Bug #825780 reported by Vladimir Savic on 2011-08-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Diederik van Lierop

Bug Description

I find that way New measurement tool represents on-screen informations is more useful then current snapping ones. It would be very nice to have that semi-transparent rectangles surround textual snapping information. Preferably even differently colored rectangles for different snapping targets.

su_v (suv-lp) on 2011-08-13
tags: added: snapping ui
su_v (suv-lp) wrote :

The UI of the measure tool (formatting of the labels for the measured path sections temporarily displayed on-canvas) was implemented for the feature request:
Bug #800052 “improve measure tool readability” (based on <http://cuts.thinking-garment.com/273>)
<https://bugs.launchpad.net/inkscape/+bug/800052>

Changed in inkscape:
importance: Undecided → Wishlist
su_v (suv-lp) wrote :

Implemented in r10816:
1) Fix CanvasText alignment bugs caused by static variables, uninitialized variables, and variable border width
2) Snap tooltips no longer overlap with measure tool tooltips, and now have a background color (similar to the measure tool)

Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)
milestone: none → 0.49
status: New → Fix Committed

Beautiful! :)

Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers