Gimp XCF export fails when layer id contains a space character

Bug #821435 reported by jazzynico on 2011-08-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

Following bug #642417 "Will not save .xcf file".

When a layer id attribute contains a space character, Gimp XCF export fails with the following error:
----
Traceback (most recent call last):
  File "gimp_xcf.py", line 234, in <module>
    e.affect()
  File "/usr/local/share/inkscape/extensions/inkex.py", line 227, in affect
    self.effect()
  File "gimp_xcf.py", line 220, in effect
    x = open(xcf, 'rb')
IOError: [Errno 2] No such file or directory: '/tmp/tmpgfNt9V/footwork.svg.xcf'
----

Test SVG file attached. Replacing id="f11 " with id="f11" fixes the issue.

jazzynico (jazzynico) wrote :
jazzynico (jazzynico) on 2011-08-25
Changed in inkscape:
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

The attached file should fix the bug (tested on Windows XP).

jazzynico (jazzynico) wrote :

Fix committed, trunk revision 10592.

Changed in inkscape:
status: In Progress → Fix Committed
tags: added: backport-proposed
jazzynico (jazzynico) wrote :

Back-ported to the 0.48.x branch, revision 9828.

Changed in inkscape:
milestone: 0.49 → 0.48.3
tags: removed: backport-proposed
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments