"encountered an internal error and will close now" upon a starting with this specific file

Bug #818082 reported by doniks on 2011-07-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Krzysztof Kosinski

Bug Description

i have a specific svg file and when i try to open it with inkscape i get a window saying "Inkscape encountered an internal error and will close now." with other files i have no problem. this file has been exported from some other application and i would'nt wonder if there is something erroneous in it, but it would be nice if inkscape could offer some hint on what is wrong with the file and i guess "an internal error" may be something that could be fixed in inkscape.

i use inkscape 0.48 installed from apt-get on kubuntu 11.04

in the terminal i get:
inkscape error.svg
terminate called after throwing an instance of 'Geom::ContinuityError'
  what(): lib2geom exception: Non-contiguous path (2geom/path.cpp:97)

in gdb i get:
gdb --args inkscape error.svg
GNU gdb (Ubuntu/Linaro 7.2-1ubuntu11) 7.2
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/inkscape...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/inkscape error.svg
[Thread debugging using libthread_db enabled]
[New Thread 0x932fab70 (LWP 14722)]
[New Thread 0x928ffb70 (LWP 14723)]
[New Thread 0x918eeb70 (LWP 14724)]
terminate called after throwing an instance of 'Geom::ContinuityError'
  what(): lib2geom exception: Non-contiguous path (2geom/path.cpp:97)

Program received signal SIGABRT, Aborted.
0xb7fe1424 in __kernel_vsyscall ()
(gdb) bt
#0 0xb7fe1424 in __kernel_vsyscall ()
#1 0xb6316e71 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#2 0xb631a34e in abort () at abort.c:92
#3 0xb65300b5 in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#4 0xb652dfa5 in ?? () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#5 0xb652dfe2 in std::terminate() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#6 0xb652e14e in __cxa_throw () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#7 0x087302b4 in ?? ()
#8 0x086d3a57 in ?? ()
#9 0x086d6d08 in ?? ()
#10 0x081aeb57 in ?? ()
#11 0x081b1e17 in ?? ()
#12 0x081a872a in ?? ()
---Type <return> to continue, or q <return> to quit---
#13 0x081aab7d in ?? ()
#14 0x081a872a in ?? ()
#15 0x081aab7d in ?? ()
#16 0x081a872a in ?? ()
#17 0x081aab7d in ?? ()
#18 0x081a872a in ?? ()
#19 0x081aab7d in ?? ()
#20 0x081a872a in ?? ()
#21 0x085c7efc in ?? ()
#22 0x081d0dfe in ?? ()
#23 0x081d0dfe in ?? ()
#24 0x081d02bc in ?? ()
#25 0x081d0032 in ?? ()
---Type <return> to continue, or q <return> to quit---
#26 0x081d0032 in ?? ()
#27 0x081d36e4 in ?? ()
#28 0x081d38ae in ?? ()
#29 0xb704d311 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0xb7051aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0xb7052270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0xb705292b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0xb7627c39 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#34 0xb7e37357 in Gtk::Main::run_impl() () from /usr/lib/libgtkmm-2.4.so.1
#35 0xb7e37d42 in Gtk::Main::run() () from /usr/lib/libgtkmm-2.4.so.1
#36 0x08086cb3 in ?? ()
#37 0x081713ea in ?? ()
#38 0x0808601a in ?? ()
---Type <return> to continue, or q <return> to quit---
#39 0xb6302e37 in __libc_start_main (main=0x8085c20, argc=2, ubp_av=0xbffff1b4, init=0x876b3d0, fini=0x876b430, rtld_fini=0xb7ff0a50, stack_end=0xbffff1ac) at libc-start.c:226
#40 0x08084a61 in ?? ()
(gdb)

if i shall provide any other information let me know

doniks (kaabud-lp) wrote :
Alvin Penner (apenner) wrote :

not sure what the file was intended to look like, but here is what I get on Windows XP, loading it into Inkscape rev 10509, and then saving it again. The original file was not viewable in IE9, but the saved file is viewable in IE9.

su_v (suv-lp) wrote :

From the SVG file:

<!--
     SVG
     Creator: LEDA GraphWin SVG - Export
     CreationDate: Fri Jul 29 16:08:48 2011
 -->

None of various tested SVG renderer seems to be able to display the SVG file created by "LEDA GraphWin SVG - Export" without what looks like rendering glitches:

- Inkscape 0.48.1: crash (backtrace attached)
- Inkscape 0.48.2: crash (see 0.48.1)
- Inkscape 0.48+devel r10516: no crash, but rendering errors with what appear to be connector lines from the data points to an upper left origin.
- Squiggle (Batik 1.7): doesn't display the file due to invalid SVG on line 103:
«The attribute "points" of the element <polyline> is invalid»
- rsvg-view (librsvg 2.34.0): vertical infinite(?) lines pointing down from what appears to be data points
- Firefox 3.6, Safari 5.0, Opera 11.5: complain about (missing) style information
- Chromium 14: nothing displayed

tags: added: 2geom crash
su_v (suv-lp) wrote :

Crash reproduced with builds from the 0.48.x branch and 0.48+devel r10325 (old renderer)
Crash not reproduced with latest revision of the cairo-rendering branch and current trunk (r10516) - likely fixed with new cairo-renderer.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
importance: Undecided → High
milestone: none → 0.49
status: New → Fix Committed
doniks (kaabud-lp) wrote :

thanks. it also doesnt crash for me when compiled from source (i think i got rev 10517 -- im new to bazar)

what apenner attached is what i /intended/ it to look like but on and off i had problems when exporting from LEDA[1]

i think what suv noticed:
> rendering errors with what appear to be connector lines from the data points to an upper left origin.
is indeed not what i /intended/ with the drawing but its probably a bug in leda.

NB: in gwenview 2.7.0 and in the information panel of dolphin 1.7 (kde 4.7.00) these connector lines are not beeing shown.

[1] http://www.algorithmic-solutions.com/leda/index.htm

Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers