inconsistent rendering of endpoint markers for vertical line

Bug #813829 reported by Alvin Penner on 2011-07-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Johan Engelen

Bug Description

attached is an svg file with two arrows in it, produced using the Visualize Path->Dimensions extension.
- when I load this into Inkscape 0.48.1 the image is normal with one horizontal and one vertical arrow
- when I load this into rev 10450, then the endpoints on the vertical arrow are misplaced and are horizontal instead of vertical.

Alvin Penner (apenner) wrote :
su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48.1 and 0.48.x r9819 (0.48.2)
Reproduced with Inkscape 0.48+devel r10325 (pre-merge of cairo-rendering) and r10481
(tested on Mac OS X 10.5.8 (i386))

tags: added: markers regression
Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
su_v (suv-lp) wrote :

Dislocation of the rendered markers disappears after forcing a rewrite of the path data and style atttributes (e.g. select all, or 'Ctrl+select' the vertical dimension line, and nudge with arrow keys).

Old path data (exposes bug):

      <path
         d="M 208.597550 250.876164 H 565.620290"
         marker-start="url(#Arrow1Lstart)"
         marker-end="url(#Arrow1Lend)"
         stroke-width="1"
         id="path3103" />

After a rewrite of the object (renders correctly):

      <path
         d="m 208.59755,250.87616 357.02274,0"
         id="path3103"
         inkscape:connector-curvature="0"
         style="stroke-width:1;marker-start:url(#Arrow1Lstart);marker-end:url(#Arrow1Lend)" />

Only affects the start/end markers of the vertical dimension lines.

su_v (suv-lp) wrote :

Correction: wrong path ID copy&pasted in previous comment: the trigger appears to be the 'V' path command:

Bug exposed:

      <path
         d="M 158.597550 300.876164 V 447.964177"
         marker-start="url(#Arrow1Lstart)"
         marker-end="url(#Arrow1Lend)"
         stroke-width="1"
         id="path3109" />

Rendering of marker ok (relative path commands):

      <path
         d="m 158.59755,300.87616 0,147.08802"
         marker-start="url(#Arrow1Lstart)"
         marker-end="url(#Arrow1Lend)"
         stroke-width="1"
         id="path3109" />

Rendering of marker ok (absolut path commands):

      <path
         d="M 158.59755,300.87616 158.59755,447.96418"
         marker-start="url(#Arrow1Lstart)"
         marker-end="url(#Arrow1Lend)"
         stroke-width="1"
         id="path3109" />

Changed in inkscape:
status: Confirmed → Triaged
su_v (suv-lp) wrote :

Not reproduced with r10019, reproduced with r10031 on Mac OS X 10.5.8 (i386)

Possibly regression introduced with 2geom update in r10025?
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/10031>

tags: added: 2geom
Alvin Penner (apenner) wrote :

- attached is a modified version of file src/2geom/hvlinesegment.h, which fixes it for me on Windows XP.
- any testing would be welcome; since this is part of 2geom, I'll request feedback from the mailing list.

Johan Engelen (johanengelen) wrote :

I have fixed this in 2geom (in a way that does not depend on the definition of 'axis') and committed to Inkscape too. Thanks for pointing to the fix Alvin.

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
milestone: none → 0.48.3
status: Triaged → Fix Committed
milestone: 0.48.3 → 0.49
su_v (suv-lp) wrote :

inkscape trunk: r10560

Changing status to 'Fix Released' in Inkscape - only occurred in trunk and never affected a stable release version [1].

[1] <http://wiki.inkscape.org/wiki/index.php/Bug_management#Bug_status>

Changed in inkscape:
milestone: 0.49 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers