Inkscape uses deprecated GtkObject API

Bug #813212 reported by Alex Valavanis on 2011-07-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alex Valavanis

Bug Description

Inkscape currently uses the deprecated GtkObject API in a few places. This has been removed in GTK+ 3, and superseded by GObject and GtkWidget.[1] The "destroy" signal is used in a few places in non-widget objects.

[1] http://developer.gnome.org/gtk3/stable/ch25s02.html#id1359496

tags: added: build
jazzynico (jazzynico) on 2011-07-25
Changed in inkscape:
importance: Undecided → Medium
status: New → Triaged
Alex Valavanis (valavanisalex) wrote :

Assigning this to Krzysztof, following previous discussions about rewriting SPCanvasItem (derived from GtkObject). Please feel free to revert if you'd prefer not to take this one!

* http://article.gmane.org/gmane.comp.graphics.inkscape.devel/36971/match=gtkobject
* http://article.gmane.org/gmane.comp.graphics.inkscape.devel/37607/match=gtkobject

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
Alex Valavanis (valavanisalex) wrote :

SPCanvasItem no longer derives from GtkObject since lp:inkscape r11470. This solves a major chunk of the remaining build issues.

Alex Valavanis (valavanisalex) wrote :

All fixed in lp:inkscape r11473

Changed in inkscape:
assignee: Krzysztof Kosinski (tweenk) → Alex Valavanis (valavanisalex)
milestone: none → 0.49
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints