Inkscape requires Cairo >= 1.10 dependency

Bug #812816 reported by Cafuego on 2011-07-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

As of a few days ago, Inkscape trunk has stopped building for Lucid. I've attached the build log generated by Launchpads build system. Both i386 and amd64 builds fail with the same error.

Builds for newer Ubuntu releases seem to still work fine.

su_v (suv-lp) wrote :
tags: added: build renderer-cairo
Changed in inkscape:
status: New → Confirmed
Alex Valavanis (valavanisalex) wrote :

The relevant section is:

  CXX desktop.o
In file included from desktop.cpp:77:
display/canvas-arena.h:51: error: ISO C++ forbids declaration of 'cairo_region_t' with no type
display/canvas-arena.h:51: error: expected ';' before '*' token

The build failure occurs because Lucid provides cairo version 1.8.10, but the "cairo_region_t" symbol is only available in cairo >= 1.10.[1]

I guess we need to introduce a strict cairo >= 1.10 version dependency for pkg-config. Any thoughts on this?

[1] http://cairographics.org/manual/cairo-Regions.html#cairo-region-t

summary: - Build fails on Ubuntu 10.04.1 LTS (Lucid)
+ Build fails with Cairo < 1.10
tags: added: cairo
removed: renderer-cairo

@Cafuego - The link in comment #2 indicates that Inkscape really does need Cairo >= 1.10 (preferably >= 1.11.2). Unfortunately, I guess you'll either need to add a Cairo package to your PPA or drop support for Lucid.

summary: - Build fails with Cairo < 1.10
+ Inkscape requires Cairo >= 1.10 dependency
Changed in inkscape:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
assignee: nobody → Alex Valavanis (valavanisalex)
milestone: none → 0.49
Alex Valavanis (valavanisalex) wrote :

Marking as "Fix Released" in trunk r10476. I have added a version dependency for Cairo >= 1.10 to prevent builds from being attempted unless the correct library version is available.

Changed in inkscape:
assignee: Alex Valavanis (valavanisalex) → nobody
milestone: 0.49 → none
su_v (suv-lp) wrote :

AFAIU based on a discussion on irc earlier today it is not yet decided whether to really drop support for Ubuntu 10.04 LTS (at least during the migration period from GTK2 to GTK3). Needs to be addressed and further discussed (alternatives, any other issues besides cairo version, etc.) on the mailing list IMHO.

Alex Valavanis (valavanisalex) wrote :

Ah OK. If there are ways of providing alternative code that compiles with cairo 1.8, that would fix support for Ubuntu 10.04. Given that development is moving towards GTK+ 3 (and friends) it will become increasingly difficult to provide alternatives for old library support. I guess the question is "when" rather than "if" we will drop support for old OS versions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers