Memory leaks

Bug #812497 reported by Reijo Tomperi on 2011-07-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Kris

Bug Description

(revision 10464)
# Allocated with g_strdup_printf() but never released
[../inkscape/inkscape/src/io/ftos.cpp:416]: (error) Memory leak: p

# Leak in success case. How serious this is, depends on how often JarFile::read_signature() is called
[../inkscape/inkscape/src/io/inkjar.cpp:153]: (error) Memory leak: bytes

# Leak in failure case
[../inkscape/inkscape/src/io/inkjar.cpp:217]: (error) Memory leak: bytes

# Memory allocated by strdup() should be released by free()
[../inkscape/inkscape/src/io/streamtest.cpp:243]: (error) Memory leak: testpath

# If only pixels or rows allocation is succesfull, only "me" is freed and the succesfull one is left unreleased. Very unlikely to happen
[../inkscape/inkscape/src/trace/imagemap.cpp:85]: (error) Memory leak: me.pixels

# Singleton, probably not worth doing anything about it (especially since it is for debug), but one could create a release() method where the dialog is released and call it at the end of execution.
[../inkscape/inkscape/src/ui/dialog/debug.cpp:156]: (error) Memory leak: debugDialog

Reijo Tomperi (aggro80) wrote :

Forgot these from the list:

# probably minor issue
[../inkscape/inkscape/buildtool.cpp:6985]: (error) Resource leak: f

# probably minor issue
[../inkscape/inkscape/buildtool.cpp:9796]: (error) Resource leak: f

su_v (suv-lp) on 2011-07-19
Changed in inkscape:
assignee: nobody → Jon A. Cruz (jon-joncruz)
status: New → Confirmed
Kris (kris-degussem) wrote :

In the mean time fixed first one. Can have a look in the other ones as well ...

Kris (kris-degussem) on 2011-07-20
Changed in inkscape:
importance: Undecided → Medium
assignee: Jon A. Cruz (jon-joncruz) → Kris (kris-degussem)
milestone: none → 0.48.3
Kris (kris-degussem) wrote :

Fix committed in trunk revision 10483.
Fix committed in inkscape 0.48.x revision 9822.

Changed in inkscape:
status: Confirmed → Fix Committed
Kris (kris-degussem) on 2012-01-01
tags: added: performance
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers