Crash when changing width/height of a clipped object (regression)

Bug #811819 reported by su_v on 2011-07-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Diederik van Lierop

Bug Description

Follow-up report to bug #212768 (originally reported by KatteKrab on irc for r10450 (Ubuntu), based on this file: <http://imgh.us/crash-test-file.svg>)

Resizing a clipped object by changing the width (or height) value on the controls bar of the select tool causes Inkscape to crash.

Steps to reproduce:
1) launch Inkscape with default preferences
2) draw two overlapping rectangles
3) select both and set a clip
4) select the clipped rectangle and change the width on the controls bar of the select tool

-> crash:

**
ERROR:sp-item-transform.cpp:252:Geom::Affine get_scale_transform_with_unequal_stroke(const Geom::Rect&, const Geom::Rect&, bool, gdouble, gdouble, gdouble, gdouble): assertion failed: (r0w >= 0)

Notes:
- crash does not occur when using the mouse to stretch the clipped object on-canvas
- 'Scale stroke width' does not matter - crash occurs with either setting.

Not reproduced with Inkscape 0.48.1, 0.48+devel r10436
Reproduced with r10439 (former r10442) and r10463
on Mac OS X 10.5.8 (i386), GCC 4.2.1, compiled with '-g -O0')

su_v (suv-lp) wrote :

@Diederik - assigning to you, since the crash seems related to the changes committed in r10439 for bug #212768 (originally r10442, which was removed and later merged with r10439). Please revert if this assignment was done in error.

Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)
description: updated

Fixed in rev. #10464. A clipped object has a visual bounding box that is smaller than the geometric bounding box, which can't be handled by the new scaling code. It should not crash however, so that has been fixed. We are still not able though to calculate the exact dimensions in such a case, so if your clipped object has a stroke and you enter a new width then it will likely end up with a width different from what you just entered.

Changed in inkscape:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers