Inkscape crashes in print preview

Bug #806105 reported by Erik Marcel Heller on 2011-07-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Krzysztof Kosinski
Debian
Invalid
Undecided
Unassigned

Bug Description

After pressing the "Preview" button in the printing dialog, Inkscape crashes.

This error always happens.
System: Debian Unstable (aptosid)
Inkscape version: 0.48+devel-r

Backtrace:

GNU gdb (GDB) 7.2-debian
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
(gdb) exec-file /usr/bin/inkscape
(gdb) run
Starting program: /usr/bin/inkscape
[Thread debugging using libthread_db enabled]
[New Thread 0x914e4b70 (LWP 7320)]
[New Thread 0x90ce3b70 (LWP 7321)]
[Thread 0x914e4b70 (LWP 7320) exited]
[New Thread 0x914e4b70 (LWP 7322)]
[Thread 0x90ce3b70 (LWP 7321) exited]
inkscape: /build/buildd-cairo_1.10.2-6-i386-PYc1QO/cairo-1.10.2/src/cairo-surface.c:637: cairo_surface_destroy: Zusicherung »((*&(&surface->ref_count)->ref_count) > 0)« nicht erfüllt.

Program received signal SIGABRT, Aborted.
0xb7fe2424 in __kernel_vsyscall ()
(gdb) bt
#0 0xb7fe2424 in __kernel_vsyscall ()
#1 0xb6136911 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#2 0xb6139d42 in abort () at abort.c:92
#3 0xb612fb28 in __assert_fail (assertion=0xb658e52c "((*&(&surface->ref_count)->ref_count) > 0)",
    file=0xb658e4e0 "/build/buildd-cairo_1.10.2-6-i386-PYc1QO/cairo-1.10.2/src/cairo-surface.c", line=637,
    function=0xb658fa88 "cairo_surface_destroy") at assert.c:81
#4 0xb653499f in cairo_surface_destroy () from /usr/lib/libcairo.so.2
#5 0xb65ece6b in ?? () from /usr/lib/libgdk_pixbuf-2.0.so.0
#6 0xb64a800c in g_object_unref () from /usr/lib/libgobject-2.0.so.0
#7 0xb65ececb in gdk_pixbuf_unref () from /usr/lib/libgdk_pixbuf-2.0.so.0
#8 0x08411f69 in ?? ()
#9 0x3ff00000 in ?? ()

EDIT: Also happens while trying to print the document

su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48.1 and 0.48+devel r10325
Reproduced with latest cairo-rendering branch, Inkscape 0.48+devel r10330 and r10416
(both with cairo 1.10.2 and cairo 1.11.2)

-> regression introduced with the merge of the cairo-rendering branch.

tags: added: regression
removed: 0.48 0.48+devel-r always debian dialog libcairo preview print unstable
Changed in inkscape:
importance: Undecided → High
status: New → Triaged
su_v (suv-lp) wrote :

Trigger appears to be SVG filter effects - random file used for the backtrace:
<https://bugs.launchpad.net/inkscape/+bug/806028/+attachment/2192693/+files/806028-bad-shadow-1.svg>

A linked or embedded bitmap does not trigger the crash, nor do regular paths or an empty document.

tags: added: filters-svg
description: updated
su_v (suv-lp) wrote :

Same crash and backtrace when saving a copy as PDF in current trunk, e.g. with the test file attached to
Bug #808898 “Inkscape does not correctly render svg and pdf files when using complex filters.”

tags: added: renderer-cairo
Alvin Penner (apenner) wrote :

not entirely sure if this is the same bug, but I think it is. On Windows XP, bzr rev 10444, if I load the attached file, which contains just a blurred rectangle:

Alvin Penner (apenner) wrote :

then try to print it, get a crash with the message:

Changed in inkscape:
status: Triaged → Confirmed
Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)

@Alvin Penner

Can't reproduce it on debian unstable.
Rectangle is not blurred, here.

Changed in debian:
status: New → Invalid
Changed in inkscape:
status: Confirmed → Fix Released
Alvin Penner (apenner) wrote :

thanks Krzysztof, that fixed it for me on XP..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers