Visual bounding box no longer matches transformed stroke

Bug #805793 reported by su_v on 2011-07-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Krzysztof Kosinski

Bug Description

Folllow-up report to
Bug #165715 “Stroke to path squashes scaled lines (renderer is wrong)”
Bug #805392 “Circle resizing do not preserve stroke width”

The new cairo renderer applies the stroke width before the explicit 'transform' attribute (of the current object or a parent node) - in accordance to the SVG specification - but the selection cue of the visual bounding box still uses the old renderer's mode (apply transform to the object geometry, then apply the stroke width) and no longer matches the precise visual dimensions of the selection.

Ofc not only affects the visual cue of the bbox, but also Snapping (Snap bounding box corners), Align & Distribute and Rows & Columns (always use the visual bbox), as well as the numeric dimensions of the visual bbox of the selection as displayed in the select tool controls bar.

Inkscape 0.48+devel r10414 on Mac OS X 10.5.8 (i386)

su_v (suv-lp) wrote :
su_v (suv-lp) wrote :

SVG file used for screenshot

description: updated
su_v (suv-lp) on 2011-07-05
tags: added: renderer-cairo
su_v (suv-lp) on 2011-07-05
description: updated
su_v (suv-lp) wrote :

In progress (with the removal of libnr in r10589): current trunk does use the correct visual bbox.

See related discussion in
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/37154/focus=37165>

(hesitating to close as 'Fix Released' until the performance regressions due to new (more precise) bbox calculation are fully solved)

Changed in inkscape:
status: New → In Progress
su_v (suv-lp) wrote :

~suv wrote on 2011-09-17:
> In progress (with the removal of libnr in r10589): current trunk does use the
> correct visual bbox.

Tests redone with latest r10535 (64bit) on OS X 10.7.4 confirm the issue as originally reported to be fixed: the visual bounding box frame, 'Snap bounding boxes', 'Align and Distribute' and 'Rows and Columns' now all work as expected

> (hesitating to close as 'Fix Released' until the performance regressions due to new
> (more precise) bbox calculation are fully solved)

Changes to improve performance of stroked paths is being tracked in
Bug #906952 "Low performance while manipulating spirograph paths"
<https://bugs.launchpad.net/inkscape/+bug/906952>

-> closing this report as 'Fix Released'.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers