Text and Font dialog: Gtk-WARNING "widget not within a GtkWindow"

Bug #805644 reported by su_v on 2011-07-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Alex Valavanis

Bug Description

Since r10280, this warning is output to the console when opening the 'Text and Font…' dialog:

Gtk-WARNING **: gtkwidget.c:5679: widget not within a GtkWindow

According to JonCruz (on irc) "I think I see the problem there. We tell the widget to grab controll and focus away from the current system, but there is no system because the widget had not been placed into any container yet"

Reproduced with Inkscape 0.48+devel r10280 and later revisions,
- Mac OS X 10.5.8 (i386)
- gtk2 2.24.4
- gtkmm 2.24.0

su_v (suv-lp) wrote :

Backtrace with '--g-fatal-warnings' (r10414 on Mac OS X 10.5.8 (i386))

su_v (suv-lp) wrote :

@Alex, subscribing you to this report - could you take a look if r10280 requires additional changes to 'src/dialogs/text-edit.cpp'?

su_v (suv-lp) on 2011-07-04
description: updated
Alvin Penner (apenner) on 2011-07-04
Changed in inkscape:
status: New → Confirmed
Alex Valavanis (valavanisalex) wrote :

Should be fixed in trunk r10419. Please check :)

su_v (suv-lp) wrote :

No more warnings on the console when opening the 'Text and Font…' dialog in r10419. Thx :)

Changed in inkscape:
assignee: nobody → Alex Valavanis (valavanisalex)
importance: Undecided → Low
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers