no File->Save As... dialog box if previously opened a file from root directory of a drive

Bug #805095 reported by Alvin Penner on 2011-07-03
174
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alvin Penner

Bug Description

this is most likely a Win32 bug.
- on Windows XP, bzr rev 10356:
- start Inkscape and load an svg file from a USB drive E:
- click on File->Save As..., nothing happens, no dialog box opens

scenario 2:
- load an svg file from C: drive
- click on File->Save As... and save it to a USB drive E:
- the save works normally
- now click on File->Save As... again, nothing happens

- not reproduced on Windows 7, Inkscape 0.48.1

su_v (suv-lp) on 2011-07-03
tags: added: saving
LucaDC (dicappello) wrote :

I experimented this last friday for the first time, after opening a file on a mapped internal network disk (our server). It was a PDF opened for a modification. After a few tries, I had to open a new document, copy and paste all then "Save as...". After it happened again in the new document so I had to open a third and repeat the copy-paste-all.
Windows XP SP3.

su_v (suv-lp) on 2011-07-04
tags: added: win32
jazzynico (jazzynico) wrote :

Not reproduced on Ubuntu 10.10, trunk revision 10442.

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape trunk revisions 10194 and 10441.
Not reproduced with 0.47 and 0.48.1.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
tags: added: regression
Alvin Penner (apenner) wrote :

this bug does not require a USB drive to be used. It appears to be triggered by any file in the root directory of a device. Save a file to C:\, then reload it from C:\ and then the Save As ... dialog will fail.

Alvin Penner (apenner) wrote :

fix committed to rev 10583

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2011-10-14
summary: - no File->Save As... dialog box if previously opened a file from a USB
- drive
+ no File->Save As... dialog box if previously opened a file from root
+ directory of a drive
su_v (suv-lp) wrote :

Raising bug importance due to incoming duplicate or related reports.
Proposing for backporting to 0.48.x

Changed in inkscape:
importance: Low → Medium
milestone: none → 0.49
tags: added: backport-proposed
Johan Engelen (johanengelen) wrote :

branch 0.48.x rev 9768 has nothing to do with this i hope?

Johan Engelen (johanengelen) wrote :

ah wait, it's been fixed :)

Johan Engelen (johanengelen) wrote :

backported the fix from r10583 to 0.48.x

Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
milestone: 0.49 → 0.48.3
su_v (suv-lp) wrote :

@Johan - thx a lot for backporting (tag removed now).

tags: removed: backport-proposed
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
Heather Martin (a-md) wrote :

Where can I get the fix for this?

Alvin Penner (apenner) wrote :

the fix is available in Inkscape 0.48.3.1-1.exe at the site:
http://sourceforge.net/projects/inkscape/files/inkscape/0.48.3.1/

Alvin

I agree that the bug I filed duplicates this, and that the "0.48.3.1-1.exe" version corrects it.
-- Carl

To post a comment you must log in.