Inkscape: A Vector Drawing Tool

Red and blue in linked/embedded bitmap images swapped in cairo-based exports

Reported by LucaDC on 2011-07-01
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Krzysztof Kosinski

Bug Description

I get red and blue swapped in images when I try saving in PDF or PS or PNG or maybe other (I tried only these).
See the attached .svg and the saved-as... .pdf where this is clear.
I've seen a similar issue (maybe related) in bug #165793, pretty old and only when printing.
Please, fix this as soon as possible because I cannot export in any way any file with an image; the only workaround is using an older version of Inkscape.
Windows XP, rev.10393.
Thanks.

Related branches

LucaDC (dicappello) wrote :
LucaDC (dicappello) wrote :
~suv (suv-lp) wrote :

Not reproduced with Inkscape 0.48+devel r10325 on Mac OS X 10.5.8 (i386)
Reproduced with the latest rev. of the cairo-rendering branch (r9598), Inkscape 0.48+devel r10330 and r10392

-> regression due to the merge of the cairo-rendering branch.

Cairo version does not matter (reproduced with cairo 1.10.2 as well as cairo 1.11.2.

tags: added: exporting regression renderer-cairo
Changed in inkscape:
importance: Undecided → Medium
status: New → Triaged
~suv (suv-lp) wrote :

<off-topic>
> Please, fix this as soon as possible because I
> cannot export in any way any file with an image

Using the latest development builds for testing and reporting new bugs / regressions is important and highly appreciated, demanding fixes in trunk *ASAP* not so much (IMHO): Switch to the current stable Inkscape version (0.48.1) for now, if you really depend on this feature. The development builds - while usually quite stable - are not recommended for productive use and can have regressions or other serious bugs anytime.
</off-topic>

summary: - Red and blue swapped when exporting
+ Red and blue in linked/embedded bitmap images swapped in cairo-based
+ exports
~suv (suv-lp) wrote :

@Krzysztof - could you look into this issue with cairo-based exports of documents with embedded/linked bitmap images?

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
LucaDC (dicappello) wrote :

> Using the latest development builds for testing and
> reporting new bugs / regressions is important and highly
> appreciated, demanding fixes in trunk *ASAP* not so much
You're perfectly right.
Apologizes.

~suv (suv-lp) wrote :

Raising importance to 'High' since the cairo-based export formats (PDF/PS/EPS) are part of many basic workflows (including printing).

Changed in inkscape:
importance: Medium → High
Krzysztof Kosinski (tweenk) wrote :

Fixed in 10421.
This bug was never present in a stable release, so setting to fix released.

Changed in inkscape:
status: Triaged → Fix Released
LucaDC (dicappello) wrote :

Thanks a lot, also for the quick response (sorry again for the silly ASAP request).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments