Inkscape crashes when loading automatically backed up svg

Bug #802212 reported by Michael Seifert on 2011-06-26
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Johan Engelen

Bug Description

Hello development team,
Inkscape recently crashed for some reason. It showed a message that the currently loaded file could be saved before the crash. When trying to open the emergency backup, though, Inkscape exits immediately. It shows an error message that tells me an internal error has occurred.
The console output is:
inkscape: /usr/include/boost/optional/optional.hpp:578: typename boost::optional_detail::optional_base<T>::reference_type boost::optional<T>::get() [with T = Geom::Point]: Zusicherung »this->is_initialized()« nicht erfüllt.

It has to be verified whether this bug is a duplicate of bug #345371.

The attached archive contains a backtrace and the svg that is causing the error. The svg-file seems to be valid, because it shows fine in other programs.

I am running Inkscape 0.48.1 r9760 on Gentoo Linux 64 bit (kernel 2.6.39).

Just ask, if you need further information. I will check back from time to time, of course.

Thanks a lot,
Michael

Michael Seifert (mseifert) wrote :
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48+devel r10365 on Mac OS X 10.5.8 (i386)

Based on the backtrace, this crash is related to or a duplicate of
Bug #800458 “Inkscape crash when ungrouping an imported SVG with connectors”
<https://bugs.launchpad.net/inkscape/+bug/800458>

tags: added: connectors crash
Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
su_v (suv-lp) wrote :

The emergency-saved file has a single connector line without end-point and an empty 'd':

    <path
       style="fill:none;stroke:#000000;stroke-width:1px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1"
       d=""
       id="path3360-0"
       inkscape:connector-type="polyline"
       inkscape:connector-curvature="0"
       inkscape:connection-start="#g3020-1-3-2"
       inkscape:connection-start-point="d4" />

su_v (suv-lp) wrote :

the recovered file (just in case ;) )

Johan Engelen (johanengelen) wrote :

fixed the crash in r10375.
when no path data is given (d=""), Inkscape now treats end and start point to be (0,0). Is that an 'ok' fix?

Changed in inkscape:
status: Confirmed → Fix Committed
assignee: nobody → Johan Engelen (johanengelen)
milestone: none → 0.48.2
Ted Gould (ted) on 2011-09-07
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers