gtk-combo-box-text-new-with-entry introduces gtk 2.24 dependency

Bug #800565 reported by Felipe "Juca" Sanches on 2011-06-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Felipe "Juca" Sanches
Changed in inkscape:
assignee: nobody → Felipe "Juca" Sanches (felipe-sanches)
su_v (suv-lp) on 2011-06-22
tags: added: build
Alex Valavanis (valavanisalex) wrote :

Oops... sorry about that. I didn't pay enough attention to the version dependencies.

Alex Valavanis (valavanisalex) wrote :

Marking this as Low importance because the issue is pretty much fixed already through preprocessor directives. Eventually, we can just tidy things up by deleting the dead code once we drop support for gtk < 2.24.

Changed in inkscape:
status: New → Triaged
importance: Undecided → Low
Alex Valavanis (valavanisalex) wrote :

Marking this as fixed, because (a) this bit of code compiles on all supported platforms via preprocessor directives, and (b) there are now too many such instances to track!

Unfortunately, because Gtk+ has introduced so many API changes, I think we'll probably be stuck with various conditional compilations until we drop support for older distros.

Changed in inkscape:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints