Pasting objects or graphics from Powerpoint, Excel, Office 2010, pastes an image instead of grouped objects

Bug #788798 reported by edwardh on 2011-05-26
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

Inkscape 0.48.1
Windows 7 64bit
Office 2010

If you copy objects or graphics from Powerpoint or Excel 2010 and try to paste it into Inkscape, it is pasted as an image instead of a set of grouped objects. In Windows XP with Office 2003, objects are pasted as such.

su_v (suv-lp) on 2011-05-30
tags: added: clipboard importing win32
Max Payne (dj-max-payne) wrote :

Same things happens when pasting objects from LibreOffice or ArcGIS, whereas Adobe Illustrator accepts graphs and other objects has grouped objects you can ungroup and modify freely.

pRototype (regeir) wrote :

This happens also sometimes when pasting grouped objects from one Inkscape session to another.
It's a periodically bug and I haven't found an unfailing way to recreate the bug.

W7, Inkscape 0.48.4 r9939.

However, this might be another bug and I may create a separate report for that.

I have this problem when copying charts in MS Excel 2016 and pasting into Inkscape 0.92.0 and it's been like this for some time. I came here to make a feature request because I'm not actually sure whether this qualifies as a bug in an existing feature rather than an absent feature.

Oh, also, like someone else said, it works just fine when I paste into Adobe Illustrator but I can't afford a license to keep using that!

jazzynico (jazzynico) on 2017-02-17
Changed in inkscape:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers