Inkscape freezes at opening

Bug #785701 reported by on 2011-05-20
This bug affects 34 people
Affects Status Importance Assigned to Milestone
inkscape (Ubuntu)

Bug Description

Binary package hint: inkscape

I use Ubuntu 11.04 classic. Very often Inkscape freezes at opening, even if empty. We have the same problem in Ubuntu 10.04. Since I hadn't noticed it up to recently (1 month or so) it's possible that it is due to a modification in another package than Inkscape, for instance a library. But Im' not an intensive user of Inkscape.
Steps to reproduce the problem: choose in the general menu Applications → Graphics → "Inskape Vector Graphics Editor".
What happens: Inkscape is launched but, often clicking any button has no effect, resizing the window doesn't resize the inside. After a while, Inkscape's window is greyished and, if I close it, I first get a "The window 'New document 1 - Inkscape' is not responding." message. Relaunching Inkscape never solves the issue. Login out and in sometimes solves it, sometimes not.
What is expected to happen: that Inkscape respond to clicks.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: inkscape 0.48.1-2ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri May 20 19:02:33 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
 PATH=(custom, user)
SourcePackage: inkscape
UpgradeStatus: Upgraded to natty on 2011-05-01 (19 days ago) ( wrote :
Julien (jul-cornu) wrote :

Same problem here, Inkscape freezes at start on Ubuntu 11.04 Unity.

It unfreezes after some time (which can be minutes long), but shows some inconsistencies, like the disappearance of the top window menu (file, edit, etc..)

tags: added: performance
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in inkscape (Ubuntu):
status: New → Confirmed
Mark Roth (markroth8) wrote :

This was happening to me as well. I did an strace on the process and it was stuck in stat() on a file in the recent files list. The file was on a cifs-mounted NAS partition that was hung due to a network disconnect.

For others who are encountering this, it might be helpful to kill all inkscape processes and then relaunch in a terminal by typing "strace inkscape" and then pasting the last thing it prints before it hangs into this bug report.

Mark Roth (markroth8) wrote :

Actually, strange - it was a file in the recent files list of another app, not inkscape. But inkscape was trying to stat it.

Al Pagan (generamics) wrote :

Thanks to Mark Roth suggestion, I ran "strace inkscape" from the terminal, and found that Inkscape was stuck in stat-ing an unrelated file (a .csv file I'd previously opened in Geany) that was located on a computer previously connected to the network. As the computer was switched off, Inkscape was stuck trying to stat an unavailable file.

Anyone have any ideas what library is trying to stat these files? It's obviously nothing to do with Inkscape's file management (based on the fact that the list of files to stat are mostly unrelated to my Inkscape activity). I believe it may be the same library that is used in gThumb, as I've found gThumb freezes on startup when doing the same thing. Perhaps this is a Zeitgeist problem?

Changed in inkscape (Ubuntu):
importance: Undecided → Medium
Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
su_v (suv-lp) wrote :

Bug #740843 “Really slow to start because of .recently-used”

Bug #703517 “Inskscape slows down when an external drive is connected”

Christopher Stone (vvlbw) wrote :

This is a dupe of Bug #740843 as linked above.

Workaround: delete the ".recently-used.xbel" file in your home directory. Note this is not stored in Inkscape's own user configuration directory. ( wrote :

The bug also appears in Fedora 16, with no .recently-used file in the home directory.
Moreover it is not always at opening that Inkscape freezes.
The bug you quote #740843 is more recent and less developped than this one, so should be considered as a duplicate of this one, rather than the opposite.

su_v (suv-lp) wrote :

> The bug also appears in Fedora 16, with no .recently-used file in the home directory.

Recent versions of Gtk+ have changed the location of the file storing entries for recently used files on linux (Gtk+/win32 uses a different location for the same file): on linux it is now saved as
(in accordance with the XDG specification, I assume)

> Moreover it is not always at opening that Inkscape freezes.

AFAIU the file is rescanned if modified on disk, to always offer an up-to-date list in Inkscape's 'File > Open Recent…' menu. Note though that bug #740843 was only mentioned after the discussion in comments #4-6 which explicitly referred to the list of recently-used files which is stored in a single file per user and shared by all Gtk+ apps.

> The bug you quote #740843 is more recent (…)

Bug #740843 was filed on 2011-03-23, yours on 2011-05-20.

Cyril Soler (csoler-users) wrote :

Once the nfs is stale, you just can't start inkscape anymore (it hangs), so there's no possible action from the GUI in the preferences.

I solved it by editing the file ~/.config/inkscape/preferences.xml, and set to 0 the variable maxrecentdocuments. The initial value is 36.

Then inkscape starts correctly.

dogmatic69 (dogmatic69) wrote :

I have just come accross this problem on ubuntu 12.04.

using strace I can see it gets stuck on stat() for a file on a network drive that is not available.

It seems that if you wait a while, 2 minutes or so it carries on.

Kris (kris-degussem) wrote :

Based on the last comment, I had a look on the code.
I can not check the issue myself, so could any affected user check whether the attached patch on trunk solves this issue?

Changed in inkscape:
status: Confirmed → Triaged

The attachment "bug785701.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Kris (kris-degussem) wrote :

Patch committed in trunk revision 12263. Please check chether the bug is solved in the development version of inkscape.

Changed in inkscape:
assignee: nobody → Kris (kris-degussem)
milestone: none → 0.49
Steve (steve46223) wrote :

I'm running inkscape-trunk 1:0.48+devel+12337+35~quantal1 (from Kris, is that the right version to check?

If so, I'm sorry to report that the bug is still there ... it freezes a few seconds after opening, and strace shows that it is patiently waiting for stat() of various network-share files.

Brendan_P (brendan-p) wrote :

Suffering from this issue too (files in recent list on slow/unavaiable NFS shares). Temporary workaround at #11 helped me for now, thanks.

Kris (kris-degussem) wrote :

based on comment 16, commit 12263 does not seem to help. (@Steve: you've checked with a good Inscape version)

Changed in inkscape:
assignee: Kris (kris-degussem) → nobody
milestone: 0.49 → none
Martin Owens (doctormo) wrote :

I've been pondering this bug all day, I couldn't work out a safe way to test it without causing network errors.

Instead I decided to build a FUSE file-system which can be set to break on certain calls. It will freeze just like this bad network effect and we can test any kind of bad IO handling from there. See and the accompanying readme. Let me know if you are able to test and what your results are.

Helmut Fedder (helmut-fedder) wrote :

Same bug here. strace inkscape showed that the problem was a stat() of file on an nfs share that was not available.

The workaround by "Cyril Soler (csoler-users)" to set maxrecentdocuments to 0 in the file ~/.config/inkscape/preferences.xml solved the problem here.


According to the strace output Inkscape is trying to find a file on an unreachable sambashare, a file which is totally unrelated to Inkscape.

Clearing the recent file list helped

Running 12842 on Ubuntu 13.10

Kevin Shenk (batonac) wrote :

I can confirm that the bug effects me in 13.10. Using the maxrecentdocuments fix from also solved the problem here.

I had noticed that the recent documents menu never worked for me. Every time I selected an item it would open a different file from the same list...

Mario Luzeiro (mrluzeiro) wrote :

Same issue here. Linux Mint 17. inkscape 0.48
It happen to me after I try to put the program in fullscreen

Brian Beers (n-ubuntuone-5) wrote :

Same issue on Windows 8 Enterprise with a network drive unavailable.
Inkscape hangs for several minutes after launch.

Hannes Roest (hannesroest) wrote :

I have a similar issue with stale smb mounts, however freezing and crashes happen also when Inkscape is already open, the smb mount is removed manually and then I try to save an already open file in Inkscape (a file that is on the local harddisk)

Simon Wenner (nowic) wrote :

Still an issue on 14.04.3. I have an NFS share which is offline some times. All Inkscape files are local, but it still freezes for ever.

Dan Benton (dogsbody) wrote :

+1 I have a SSHFS drive mounted and for some reason it seems Inkscape is trying to stat 100s of recently accessed files over this really slow connection which causes it to lock up.

I can't see anything in the preferences to stop it trying to do this :-/

Ubuntu 14.04 LTS

pedrogaza (pubpedro) wrote :

Same problem for me. Strace show me that the problem is related to a file with no link with inkscape.
Deleting ~/.local/share/recently-used.xbel solve the problem.

Would it be possible to deactivate recent file feature ?

Berthold (bsc1976) wrote :

Inkscape freeze on startup. Strace showed it tried to access a file on an unavailable network drive.

Deleted history as described here made it work again:

rm ~/.local/share/zeitgeist/activity.sqlite
zeitgeist-daemon --replace

rm ~/.local/share/zeitgeist
zeitgeist-daemon --replace

Ubuntu 14.04
Inkscape 0.91 r

Same bug running Ubuntu 16.04 and inkscape 0.91 r13725.

In my case this is due to a file that was in an autofs filesystem that cannot be mounted.

The two workarounds described above solve the problem (~/.local/share/recently-used.xbel and setting maxrecentdocuments=0 in ~/.config/inkscape/preferences.xml).

Jadzia Dax (aurote) wrote :

Same bug on Gentoo (up-to-date version).

I had an sshfs mounted permanently on my filesystem.

The solution which worked was also to change the maxrecentdocuments setting to 0 in ~/.config/inkscape/preferences.xml

strahl (stef-nstrahl) wrote :

Same bug running Debian buster/sid and Inkscape 0.92.2 (5c3e80d, 2017-08-06).

In my case strace showed that Inkscape tried to access a file on a NFS mount via stat() that failed as I was on travel / not in my home LAN. The UI behaviour was that Inkscape froze and htop showed one of the Inkscape threads being in state "D" - uninterruptible sleep (usually IO).

Having a quick peek in the source code - /src/ui/interface.cpp has a function sp_ui_build_dyn_menus() which looks promising to debug - let's hope I find some time to compile Inkscape and debug soon...

mray (mrayyyy) wrote :

Closing because this can't be reproduced with 1.0alpha (1:0.92.0+devel+201904052254+98d368e) on Ubuntu.

Closed by:

tags: added: bug-migration
Changed in inkscape:
status: Triaged → Invalid
Mattia Rizzolo (mapreri) wrote :

(following upstream)

Changed in inkscape (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions