Enable build against libwpg-0.2

Bug #778951 reported by Alex Valavanis on 2011-05-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Jon A. Cruz
inkscape (Debian)
Fix Released
Unknown
inkscape (Ubuntu)
High
Unassigned

Bug Description

At the moment, configure.ac allows libwpg-0.1 to be used, but not the current libwpg-0.2. This has been fixed in Debian using the attached dpatch... however, it would be better to allow either version to be used.

Related branches

Alex Valavanis (valavanisalex) wrote :
su_v (suv-lp) on 2011-05-07
tags: added: build
su_v (suv-lp) on 2011-05-07
Changed in inkscape:
status: New → Confirmed
Changed in inkscape (Ubuntu):
status: New → Fix Released
importance: Undecided → High
Changed in inkscape (Debian):
status: Unknown → Fix Released
Changed in inkscape:
assignee: nobody → Jon A. Cruz (jon-joncruz)
Changed in inkscape:
status: Confirmed → In Progress
milestone: none → 0.48.2
Jon A. Cruz (jon-joncruz) wrote :

Trunk now should build against 0.1.x or 0.2.x, whichever is detected, as of revision 10266.

Alex Valavanis (valavanisalex) wrote :

That's great news. Shall we mark as fix committed?

Jon A. Cruz (jon-joncruz) wrote :

Backported to the 0.48.x branch as revision 9788.

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

r10267 needs to be backported to inkscape/0.48.x

tags: added: backport-proposed
su_v (suv-lp) wrote :

Sorry, my mistake, tag removed - change already committed to inkscape/0.48.x (r9791).

tags: removed: backport-proposed
Download full text (4.7 KiB)

it seems to me something's broken with (at least) revision 10549 and libwpg-0.2

I have all the header files but still get this:

x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -I/usr/include/freetype2 -fopenmp -I/usr/include/ImageMagick -I/usr/include/libwpg-0.2 -I/usr/include/libwpd-0.9 -I/usr/include/poppler -D_REENTRANT -DQT_SHARED -pthread -I/usr/include/poppler/glib -I/usr/include/poppler -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/cairo -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng14 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore -I/usr/include/pango-1.0 -DPOTRACE=\"potrace\" -pthread -D_REENTRANT -DQT_SHARED -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng14 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore -I/usr/include/libxml2 -I/usr/include/sigc++-2.0 -I/usr/lib64/sigc++-2.0/include -I/usr/include/gtkspell-2.0 -I/usr/include/glibmm-2.4 -I/usr/lib64/glibmm-2.4/include -I/usr/include/giomm-2.4 -I/usr/lib64/giomm-2.4/include -I/usr/include/gdkmm-2.4 -I/usr/lib64/gdkmm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/lib64/pangomm-1.4/include -I/usr/include/cairomm-1.0 -I/usr/lib64/cairomm-1.0/include -I/usr/include/gtkmm-2.4 -I/usr/lib64/gtkmm-2.4/include -I/usr/include/atkmm-1.6 -I/usr/include/gtk-unix-print-2.0 -I../cxxtest -I./bind/javainc -I./bind/javainc/linux -I./extension/dbus -Werror=format-security -Wall -Wformat -Wformat-security -W -D_FORTIFY_SOURCE=2 -Wpointer-arith -Wcast-align -Wsign-compare -Woverloaded-virtual -Wswitch -Wno-unused-parameter -O2 -march=core2 -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -fomit-frame-pointer -pipe -fno-strict-aliasing -fopenmp -c -o extension/internal/bitmap/imagemagick.o extension/internal/bitmap/imagemagick.cpp
extension/internal/wpg-input.cpp:59:44: error: libwpg/WPGStreamImplementation.h: No such file or directory

that's because there is no WPGStreamImplementation.h in libwpg-0.2; i can only see it in libwpg-0.1;
I cross checked with debian, as the OP reports it's working there, but it's clear from
http://packages.debian.org/sid/amd64/libwpg-dev/filelist
that there is no such file in libwpg-0.2;

I am on an up2date Gentoo box and these are the files I have for libwpg:
blackknight ~ # equery f libwpg
 * Searching for libwpg ...
 * Contents of app-text/libwpg-0.1.3:
/usr
/usr/bin
/usr/bin/wpg2raw
/usr/bin/wpg2svg
/usr/bin/wpg2svgbatch.pl
/usr/include
/usr/include/libwpg-0.1
/usr/include/libwpg-0.1/libwpg
/usr/include/libwpg-0.1/libwpg/WPGBinaryData.h
/usr/include/libwpg-0.1/libwpg/WPGBitmap.h
/usr/include/libwpg-0.1/libwpg/WPGBrush.h
/usr/include/libwpg-0.1/libwpg/WPGColor.h
/usr/include/libwpg-0.1/libwpg/...

Read more...

Ted Gould (ted) on 2011-09-07
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.