Inkview rendering with incorrect scaling when slide showing multiple files.

Bug #771365 reported by Thinker on 2011-04-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Thinker

Bug Description

If you use inkview to load multiple files, you will get incorrect scaling when you switching among files with different page size. For example, you load two files, first one is with big page size, and later one is with small page size. When you switch to second file (page down)from first file, the scaling factor for showing second file is 1, but it should rescale the file to fill the window. After that, you can switch back to first file (page up), you will see first file being scaling up, bigger than expected.

The bug is caused by SPSVGView::setDocument() using page size of old document (previous one) to compute scaling factor of new one.

Thinker (thinker) wrote :
su_v (suv-lp) on 2011-04-26
tags: added: inkview
jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape trunk revision 10342.

Changed in inkscape:
importance: Undecided → Low
milestone: none → 0.49
status: New → Triaged
jazzynico (jazzynico) wrote :

Patch tested successfully on Windows XP and Ubuntu 10.10.
Committed in the trunk, revision 10376.
Thanks!

Changed in inkscape:
status: Triaged → Fix Committed
assignee: nobody → Thinker (thinker)
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers