Connector between clones incorrectly moved if an original objcet is moved

Bug #746294 reported by su_v on 2011-03-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

Follow-up to bug #745784:

Moving the original of a clone (the clone has a connector line attached), triggers an incorrect redraw of the connector attached to the clone.

Steps to reproduce:
1. Open new document, draw 2 rectangles
2. Draw a connector between the rectangles
3. Clone each shape and drag to a nearby location
4. Draw a connector between the clones
5. Select one of the original rectangles and move it

Expected result:
The connector between the originals gets recalculated and updated, the clones and their connector line stays unchanged.

Actual result:
Additionally the connector point of the clone of the original is incorrectly moved, too (inversely compensating the move of the original).

Not reproduced with Inkscape 0.47,
reproduced with Inkscape 0.48.0, 0.48.1 and 0.48+devel r10133 on OS X 10.5.8 (i386),
with default preferences (i.e. clones stay unmoved when the original is moved).

su_v (suv-lp) wrote :
tags: added: regression
su_v (suv-lp) wrote :

The incorrect routing only persists in the current session: saving and reopening the file updates the connector end points correctly.
Possibly related: bug #723248, bug #795614

jazzynico (jazzynico) wrote :

Confirmed on Debian Wheezy, Inkscape trunk revision 11512.

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
jazzynico (jazzynico) on 2012-09-05
Changed in inkscape:
status: Confirmed → Triaged
jazzynico (jazzynico) wrote :

Reproduced again on Windows XP, Inkscape trunk revision 12228.

Beluga (buovjaga) wrote :

Tried with attached file and from scratch, but could not repro.

Arch Linux 64-bit, KDE Plasma 5
Inkscape 0.92+devel 15099 (GTK3)

su_v (suv-lp) wrote :

Based on tests with archived trunk builds:
- reproduced with rev <= 13447,
- not reproduced with rev >= 13449;
the regression was likely addressed as side-effect of rev 13448 (for otherwise unrelated bug #1322940).

Can be closed as 'Fix Released' with milestone 0.91.

jazzynico (jazzynico) on 2016-09-02
Changed in inkscape:
milestone: none → 0.91
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers