SVG to XAML fails creating valid doubles on German Windows 7 / 64

Bug #746290 reported by Monsti on 2011-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico

Bug Description

The converter creates illegal XAML code on my German Windows 7 / 64.

e.g.
<LinearGradientBrush ... StartPoint="241,40979,287,49377" EndPoint="315,47369,367,88477">

StartPoint="241,40979,287,49377" should be a StartPoint="241.40979,287.49377"

I think the subroutine that creates the string from double uses the system defaults settings for
creating doubles to string.

Monsti (iceh) wrote :

Testes with Version: inkscape_r10115-201103191533

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48+devel r10133 on OS X 10.5.8 (i386),
comparing the results when exporting to XAML with LANG="de_DE.UTF-8" and LANG="en_US.UTF-8" (default prefs)

tags: added: exporting
removed: win7
Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
jazzynico (jazzynico) on 2011-03-31
Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
status: Confirmed → Triaged
jazzynico (jazzynico) wrote :

The gradient start and stop points should be rounded in XAML. Patch in progress.

Please note that gradients are not correctly converted, due to differences in the way SVG and XAML work (see http://wiki.inkscape.org/wiki/index.php/SpecXAMLExport).

Changed in inkscape:
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

Fix committed in the trunk, revision 10137.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) wrote :

Backported to the 0.48.x branch, revision 9776.

Changed in inkscape:
milestone: 0.49 → 0.48.2
Ted Gould (ted) on 2011-09-07
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers