translucent filter crashes program when resizing page & extends beyond image

Bug #737813 reported by Citsym Nogard on 2011-03-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
jazzynico

Bug Description

When applying the translucent filter to a stroke it increases the drawing/selection size by approximately 1.5 times, i.e. 500px x 500px becomes 753.75px x 753.75px. The area beyond the actual drawing/selection is invisible. This creates several problems. If you use the 'Resize page to drawing or selection' button on the 'Document Properties' it crashes the program after it resizes the width. When you re-open the image you can then resize the height of the page with the button. The translucent filter seems to be the culprit behind the program crashing when trying to use the Export to Bitmap function of very large images. I'm not 100% sure of this because I'm having trouble sorting out the filters in the image (I'm exporting) due to Inkscape naming the filters with numbers & the presence of filters that where undone .

su_v (suv-lp) wrote :

Please add information about platform and Inkscape version. Could you attach a sample SVG file?

tags: added: filters-svg transformations
removed: filter phantom translucent
su_v (suv-lp) wrote :

Crash as described not reproduced with Inkscape 0.48.0, 0.48.1 and 0-48+devel r10112 on OS X 10.5.8 (i386).
Resizing attached sample SVG file to content or selection does not trigger a crash.

Platform Windows Vista
Inkscape .48

These are the steps I took to get this problem.

Since I can reproduce this every time I'm sending you a small file (500px X
500px). I can send you the larger file of the piece I'm working on, but it
is large with a lot of stuff on it. I get the same results every time, no
matter the file though.

I started the demo with 500px X 500px page size.

1. draw stroke path with the bezier tool.
2. set stroke with to 2.5.
3. Apply Translucent filter.
4. Center selection to page.
5. Save file.
6. Open Document Properties dialog.
7. Click plus sign next to Resize page content...
8. Click Resize page to drawing or selection button.
9. Get Error message:
Inkscape encountered an internal error and will close now.
Automatic backups of unsaved documents were done to the following locations:
        C:\Users\xxxxxx xxxxxx\Documents\New Folder\New
Folder\demo.svg.2011_03_18_19_44_29.0.svg
9. Reopen file & proceed as normal.

----- Original Message -----
From: "~suv" <email address hidden>
To: <email address hidden>
Sent: Friday, March 18, 2011 4:52 PM
Subject: [Bug 737813] Re: translucent filter crashes program when
resizingpage & extends beyond image

Please add information about platform and Inkscape version. Could you
attach a sample SVG file?

** Tags added: filters-svg transformations
** Tags removed: filter phantom translucent

--
You received this bug notification because you are a direct subscriber
of the bug.
https://bugs.launchpad.net/bugs/737813

Title:
  translucent filter crashes program when resizing page & extends beyond
  image

Status in Inkscape: A Vector Drawing Tool:
  New

Bug description:
  When applying the translucent filter to a stroke it increases the
  drawing/selection size by approximately 1.5 times, i.e. 500px x 500px
  becomes 753.75px x 753.75px. The area beyond the actual
  drawing/selection is invisible. This creates several problems. If you
  use the 'Resize page to drawing or selection' button on the 'Document
  Properties' it crashes the program after it resizes the width. When
  you re-open the image you can then resize the height of the page with
  the button. The translucent filter seems to be the culprit behind the
  program crashing when trying to use the Export to Bitmap function of
  very large images. I'm not 100% sure of this because I'm having
  trouble sorting out the filters in the image (I'm exporting) due to
  Inkscape naming the filters with numbers & the presence of filters
  that where undone .

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/inkscape/+bug/737813/+subscribe

su_v (suv-lp) wrote :

Following your instructions:
reproduced with Inkscape 0.48.1 on OS X 10.5.8 (i386),
not reproduced with Inkscape 0.48+devel r10115.

@JazzyNico - can you confirm this result?

Changed in inkscape:
importance: Undecided → High
jazzynico (jazzynico) wrote :

Reproduced on Ubuntu 10.10 with 0.48.1 and trunk revision 10115.
Investigation a potential error in the filters file.

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.48.2
status: New → Confirmed
jazzynico (jazzynico) wrote :

Apparently, this is due to an incorrect in2 value in the first blend element of the filter.
The attached patch has been successfully tested with the trunk version. 0.48.x test in progress (needs to be rebuilt from scratch...).

Changed in inkscape:
status: Confirmed → In Progress
su_v (suv-lp) wrote :

> Investigation a potential error in the filters file.

Sorry, I completely forgot that my trunk build uses 'Filters alternate 10 ' from <http://www.openclipart.org/detail/filters-alternate-10-by-ivan_louette> instead of the original filers.svg which could explain why I didn't reproduce the crash with trunk.

jazzynico (jazzynico) wrote :

Fix committed in the trunk (revision 10117) and the 0.48.x branch (revision 9770).

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) wrote :

> I completely forgot that my trunk build uses 'Filters alternate 10 '

Yes, he's currently reorganizing its filters file. I've just send him an email about it. We're going to check the file to see if there are other problematic filters.

Ted Gould (ted) on 2011-09-07
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers