Resize page to selection: 'InfinityLine' start/end markers not included

Bug #733010 reported by julien on 2011-03-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned
inkscape (Ubuntu)
Low
Unassigned

Bug Description

Just a small bug... When trying to adapt the canvas size to the selected elements, it does not take into account the start/end markers in the lines, and gives a fit which does not exactly fit to the selection. (funtion resize page to drawing or selection)

julien (julien-bodart) wrote :
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48+devel r10082 on OS X 10.5.8 (i386)

tags: added: markers selection
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) wrote :

Works ok with markers like Arrow1 (resize page to selection properly includes the miters of the arrow), but not with the 'InfiniteLine' marker.

su_v (suv-lp) on 2011-03-11
summary: - Wrong selection size
+ Resize page to selection: 'InfinityLine' start/end markers not included
Johan Engelen (johanengelen) wrote :

The problem is that the infiniteline marker contains a group in the definition. If you add a group definition around the arrow marker, it also bugs.
So, now to fix that problem...

Johan Engelen (johanengelen) wrote :

Fixed the group problem now.

su_v (suv-lp) wrote :

Fix tested and confirmed with Inkscape 0.48+devel r10098 on OS X 10.5.8 (i386)

Stock markers using a group of paths in the marker definition are now completely included in the page resized to content or to selection. The resulting page is a bit larger than the actual bbox of the selection/content though.

su_v (suv-lp) wrote :

@Johan - 'In Progress' or 'Fix Committed'? ;)

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
status: Confirmed → In Progress
su_v (suv-lp) wrote :

changing status as discussed on jabber

Changed in inkscape:
assignee: Johan Engelen (johanengelen) → nobody
status: In Progress → Triaged
julien (julien-bodart) wrote :

Thanks guy, very fast!
Keep on the good job! Inkscape is a great software!

Alex Valavanis (valavanisalex) wrote :

@Johan - Please could you take a look at bug #755219, reported in Inkscape (Ubuntu)? It looks very much like a duplicate of this - what do you think?

Johan Engelen (johanengelen) wrote :

yeah, bug 755219 is duplicate

Changed in inkscape (Ubuntu):
status: New → Triaged
importance: Undecided → Low
jazzynico (jazzynico) wrote :

Tested again on Crunchbang Waldorf, trunk revision 12976.
The InfinityLine markers are now correctly included in the page size. Does someone remember why the bug is marked "Triaged" and not "Fixed committed"?

Changed in inkscape:
milestone: none → 0.91
su_v (suv-lp) wrote :

On 2014-01-24 14:25 +0100, jazzynico wrote:
> Does someone remember why the bug is marked "Triaged" and not "Fixed
> committed"?

Here's the jabber log containing the conversation I referred to in comment #8 when reverting the bug status from 'Committed' to 'Triaged' (starts at [13:25:44]):
<http://inkscape.gristle.org/2011-03-12.txt>

su_v (suv-lp) wrote :

Comment #5:
> The resulting page is a bit larger than the actual bbox of the
> selection/content though.

Testing archived trunk builds on OS X 10.7.5:
- reproduced with rev 10795, 11005, 11007, 11008, 11009
- not reproduced with rev 11500, 11250, 11128, 11072, 11034, 11021, 11010

One of the remaining issues seems to have disappeared with the changes from revision 11010 (the visual bbox now fits tightly, and page size is set correctly to the size of the visual bbox of the selection):
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/11010>

su_v (suv-lp) on 2014-01-26
Changed in inkscape:
status: Triaged → Fix Committed
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers