Inkscape: A Vector Drawing Tool

compile error when configured without lcms

Reported by Raimund Andersen on 2011-02-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Marcin Floryan

Bug Description

This affects 0.48.1; haven't had the problem with 0.48.0:

make all-recursive
make[1]: Entering directory `/var/tmp/portage/media-gfx/inkscape-0.48.1/work/inkscape-0.48.1'
Making all in src
make[2]: Entering directory `/var/tmp/portage/media-gfx/inkscape-0.48.1/work/inkscape-0.48.1/src'
  CXX arc-context.o
  CXX attributes.o
  CXX axis-manip.o
  CXX box3d-context.o
  CXX box3d.o
  CXX box3d-side.o
  CXX color.o
  CXX color-profile.o
color-profile.cpp: In static member function »static std::list<Glib::ustring> Inkscape::ColorProfile::getProfileFiles()«:
color-profile.cpp:770:34: Fehler: »sanitizeString« ist kein Element von »Inkscape::IO«
make[2]: *** [color-profile.o] Fehler 1

However, with lcms enabled, the compilation process runs fine. So it's ok for me now and I'm out here.

Greets,
Raimund

Related branches

~suv (suv-lp) wrote :

For clarification:

- OS and Compiler version?
- did you manually disable lcms first when running configure or had the necessary lcms libs and headers not been installed on your system?

Related reports on inkscape-devel:
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/35338>
<http://article.gmane.org/gmane.comp.graphics.inkscape.devel/35554>

Related bug report for gentoo:
<http://bugs.gentoo.org/show_bug.cgi?id=356285>

tags: added: build color
~suv (suv-lp) wrote :
Download full text (3.7 KiB)

> This affects 0.48.1

Reproduced building Inkscape 0.48.1 configured with 'diable-lcsm on Mac OS X 10.5.8 (i386) with GCC 4.2.1

Configuration:

        Source code location: .
        Destination path prefix: /Volumes/green/mp-inkscape/tmp/inkscape-0.48.1/packaging/macosx/../../Build
        Compiler: g++-4.2
        CPPFLAGS: -Werror=format-security -Wall -Wformat -Wformat-security -W -D_FORTIFY_SOURCE=2 -I/Volumes/green/mp-inkscape/with-a-long-long-long-directory-name/include
        CXXFLAGS: -Wpointer-arith -Wcast-align -Wsign-compare -Woverloaded-virtual -Wswitch -Wno-unused-parameter -g -O3 -Wall
        CFLAGS: -Wno-pointer-sign -g -O3 -Wall
        LDFLAGS: -L/Volumes/green/mp-inkscape/with-a-long-long-long-directory-name/lib

        Use Xft font database: yes
        Use gnome-vfs: yes
        Use openoffice files: yes
        Use relocation support: no
        Internal Python: skipped
        Internal Perl: skipped
        Enable LittleCms: no
        Enable Poppler-Cairo: yes
        ImageMagick Magick++: yes
        Libwpg: yes

LeWitt:macosx suv$ cd -
/Volumes/green/mp-inkscape/tmp/inkscape-0.48.1
LeWitt:inkscape-0.48.1 suv$ make
make all-recursive
Making all in src
  CXX arc-context.o
  CXX attributes.o
  CXX axis-manip.o
  CXX box3d-context.o
  CXX box3d.o
  CXX box3d-side.o
  CXX color.o
  CXX color-profile.o
color-profile.cpp: In static member function ‘static std::list<Glib::ustring, std::allocator<Glib::ustring> > Inkscape::ColorProfile::getProfileFiles()’:
color-profile.cpp:770: error: ‘sanitizeString’ is not a member of ‘Inkscape::IO’
make[2]: *** [color-profile.o] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
LeWitt:inkscape-0.48.1 suv$

> haven't had the problem with 0.48.0

Reproduced building Inkscape 0.48.0 configured with 'diable-lcsm on Mac OS X 10.5.8 (i386) with GCC 4.2.1

Configuration:

        Source code location: .
        Destination path prefix: /Volumes/green/mp-inkscape/tmp/inkscape-0.48.0/packaging/macosx/../../Build
        Compiler: g++-4.2
        CPPFLAGS: -Werror=format-security -Wall -Wformat -Wformat-security -W -D_FORTIFY_SOURCE=2 -I/Volumes/green/mp-inkscape/with-a-long-long-long-directory-name/include
        CXXFLAGS: -Wpointer-arith -Wcast-align -Wsign-compare -Woverloaded-virtual -Wswitch -Wno-unused-parameter -g -O3 -Wall
        CFLAGS: -Wno-pointer-sign -g -O3 -Wall
        LDFLAGS: -L/Volumes/green/mp-inkscape/with-a-long-long-long-directory-name/lib

        Use Xft font database: yes
        Use gnome-vfs: yes
        Use openoffice files: yes
        Use relocation support: no
        Internal Python: skipped
        Internal Perl: skipped
        Enable LittleCms: no
        Enable Poppler-Cairo: yes
        ImageMagick Magick++: yes
        Libwpg: yes

LeWitt:macosx suv$ cd -
/Volumes/green/mp-inkscape/tmp/inks...

Read more...

Changed in inkscape:
importance: Undecided → High
status: New → Triaged
~suv (suv-lp) on 2011-02-25
tags: added: regression
~suv (suv-lp) wrote :

@Jon - could you review the patch [1] from the gentoo bug report? The regression appears to have been introduced with
- revision 9834 in trunk:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/9834>
- revision 9689 in the 0.48.x branch:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/RELEASE_0_48_BRANCH/revision/9689>

[1] gentoo bug report & patch:
<http://bugs.gentoo.org/show_bug.cgi?id=356285#c5>
<http://bugs.gentoo.org/attachment.cgi?id=263693&action=view>

Changed in inkscape:
assignee: nobody → Jon A. Cruz (jon-joncruz)
Dmitry Dzhus (dzhus) wrote :

I think that the problem was fixed in trunk revision 9892: http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/9892

Currently I can build trunk with and without LCMS support without any extra patches.

~suv (suv-lp) wrote :

> I think that the problem was fixed in trunk revision 9892

Thanks for pointing that out! Proposing for backporting to the 0.48.x branch for 0.48.2.

tags: added: backport-proposed
Changed in inkscape:
assignee: Jon A. Cruz (jon-joncruz) → nobody
milestone: none → 0.49
status: Triaged → Fix Committed
assignee: nobody → Marcin Floryan (mfloryan)
jazzynico (jazzynico) wrote :

Back-ported to the 0.48.x branch, revision 9827.

Changed in inkscape:
milestone: 0.49 → 0.48.3
tags: removed: backport-proposed
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.