Certain PDF and/or EPS files crash when ungrouping in Inkscape

Bug #723610 reported by Jurgen Gaeremyn on 2011-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

I need to convert and edit certain .EPS files to .SVG.

When opening (or importing) the file under Windows 7 (32bits) ... Inkscape (0.48.0 r9654) gets very slow - moving mouse becomes impossible. System hangs.

So I tried installing Ubuntu 10.04 LTS (32 bits - in a virtualbox) and opened the same files using Inkscape in here. The file opens, I have the impression the program slows down slightly. When trying to ungroup the item (multiple ungroups), the system also hangs - causing Inkscape to crash. It generates an autosave file of 12 MB for an initial .EPS file of less than 100 kB, which is corrupt since it can not be opened.

Additionally: the PDF file (made using PDFsam) which I used under Windows (as I couldn't import .EPS under Windows)

su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48+devel r10067 on OS X 10.5.8 (i386)

The EPS and PDF files display correctly in evince, gs 9.01 and Apple's Preview.app.
Both files import correctly in Inkscape, and can be ungrouped recursively without crash (see attached file, EPS -> Inkscape -> ungroup until no groups left). There are however several text objects whose content appears to have been dropped on import or is already broken/missing in the original files.

The PDF file, if opened in evince, shows these warnings on the console:
Error: Illegal entry in bfrange block in ToUnicode CMap
Error: Illegal entry in bfrange block in ToUnicode CMap
Error: Illegal entry in bfrange block in ToUnicode CMap
Error: Illegal entry in bfrange block in ToUnicode CMap

tags: added: eps importing pdf
su_v (suv-lp) wrote :

Note that ungrouping all groups has changed the stack order - originally after opening the EPS/PDF file, it looks the same in Inkscape as in external renderers and the prview in the PDF import dialog.

su_v (suv-lp) wrote :

Reproduced with both files with Inkscape 0.48.0 on Mac OS X 10.5.8
Not reproduced with Inkscape 0.48.1 and current trunk.

AFAICT doesn't depend on external gs version (for EPS import), nor on cairo or poppler version (tested current trunk (r10067) built with older and current stable versions of the dependencies), but apparently only on changes in Inkscape's code (fixed for 0.48.1).

su_v (suv-lp) wrote :

> Note that ungrouping all groups has changed the stack order

Sorry, it''s not the stack order but the release of clip-paths which had been used on groups.

> Reproduced with both files with Inkscape 0.48.0

Repeated ungrouping (until nothing to ungroup in the selection) in Inkscape 0.48.0 works fine, if the the groups of "empty" text objects (within the first (lowest) group) are deleted first.

Most likely same issue as bug #369861 (fixed in trunk and for 0.48.1): saving the imported EPS as SVG (without any changes) in Inkscape 0.48.0, creates a file that fails to open again in Inkscape (parser error).

Maybe a newbie issue here... but I tried compiling Inkscape from source.
I'm running Inkscape 0.48+devel r10068 - I'll assume that's the most recent (on date of yesterday) version.

All worked well, but I can't open or import .EPS or .PDF.
(I can save as .EPS though)

Are there some additional steps that need to be done for that?

su_v (suv-lp) wrote :

> I tried compiling Inkscape from source.

On which platform? Seems that you don't have the necessary poppler packages installed (for PDF import).

For EPS import, Inkscape uses ps2pdf from Ghostscript to convert the EPS file on-the-fly to a PDF file, and then opens the PDF file using internal routines (based on poppler).

Are both file types missing in the list of available file types in the 'File > Open…' dialog?

Note that for Windows, you can download development builds from <http://inkscape.modevia.com/win32/?C=M;O=D> (updated every 7-10 days usually).

su_v (suv-lp) wrote :
su_v (suv-lp) wrote :

Setting bug status to 'Fix committed' (Milestone 0.48.1) because no crash no longer reproduced with trunk and 0.48.1 builds.
AFAICT crash is avoided due to the changes for PDF import from bug #369861 (trunk: r9812, 0.48.x: r9682).

Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.48.1
status: New → Fix Committed
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers