inkscape can't handles big files

Bug #720075 reported by hefee on 2011-02-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

If I try to open a ~18MB big svg File (created by mathplotlib http://matplotlib.sourceforge.net/). inkscapes consume ~60MB RAM and 100%CPU for hours (MD Athlon(tm) 64 X2 Dual Core Processor 3800+,3GB RAM), just for dislaying. Sometimes inkscapes ends and I can zoom in one step , wait some hours ... Link to file: http://dl.dropbox.com/u/1765188/trajectories-print.svg

Ok firefox can't display this file and konqueror open this after 20min.

running kubuntu 9.10 / Inkscape 0.48.0 r9654 (Jan 27 2011) (self compiled)

su_v (suv-lp) on 2011-02-16
tags: added: performance
nightrow (jb-benoit) on 2012-12-05
Changed in inkscape:
importance: Undecided → Low
nightrow (jb-benoit) wrote :

I tried on inkscape 0.48.2 on win7, your file take ages to open.
The file is very big (272067 lines), so i don't know if the problem is that your file is too big or if the software is too slow.

Changed in inkscape:
status: New → Confirmed
ScislaC (scislac) wrote :

Inkscape trunk actually handles this file rather well on Linux on my box. It opened in less than 30 seconds, changing zoom levels takes ~10 seconds at most in my testing.

Note: I did test against the 0.48.x tree and the performance was horrible as expected. I opened 0.48.x and chose to open that file. Window dimmed as unresponsive. While that process was running I opened a copy of current trunk, chose to open that file. It took as little time as I mentioned above, zoomed around, etc... by the time I was done and closed it, 0.48.x still hadn't become responsive yet.

Closing as Fix Committed for 0.49.

Changed in inkscape:
milestone: none → 0.49
status: Confirmed → Fix Committed
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers