Node tool causes inkscape crash

Bug #716057 reported by Martin Owens on 2011-02-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Gellule

Bug Description

Trying to open the attached svg file, inkscape fails to open. We get this error:

inkscape: libavoid/orthogonal.cpp:1747: void Avoid::buildOrthogonalChannelInfo(Avoid::Router*, size_t, Avoid::ShiftSegmentList&): Assertion `displayRoute.at(indexLow)[altDim] < displayRoute.at(indexHigh)[altDim]' failed.

Emergency save activated!

Martin Owens (doctormo) wrote :
su_v (suv-lp) on 2011-02-09
tags: added: connectors crash
su_v (suv-lp) wrote :

Crash reproduced with Inkcape 0.48+devel r10037 on OS X 10.5.8 (backtrace attached).

su_v (suv-lp) wrote :

Based on backtrace, this seems same issue as bug #635469 “[connectors] 'Exchange Position' of objects with orthogonal connectors causes crash”.

The file opens without crash (though the connector lines are routed differently), after replacing all occurrences (3) of
       inkscape:connector-type="orthogonal"
with
       inkscape:connector-type="polyline"
using an external text editor.

Changed in inkscape:
importance: Undecided → High
su_v (suv-lp) wrote :

@Martin - in the summary, you wrote "Node tool causes inkscape crash" - how is the node tool <F2> related to this report about a file that fails to open?

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) wrote :

This version should open without crash (tested with 0.48.0, 0.48.1 and 0.48+devel r10037) and render as intended (in case you are in need of a working version of the file).

Martin Owens (doctormo) wrote :

Thank you for your help suv, I used your first fix and created a new document from there. I see how the error was caused, funny how this is the second inkscape bug where inkscape created a file it could not open.

su_v (suv-lp) wrote :

Crash no longer reproduced with patch attached to bug #771738
tested with Inkscape 0.48+devel r10268+patch on Mac OS X 10.5.8 (i386)

ScislaC (scislac) on 2011-06-14
Changed in inkscape:
status: Confirmed → Fix Committed
assignee: nobody → Gellule (gellule-xg)
milestone: none → 0.48.2
Ted Gould (ted) on 2011-09-07
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers