When importing an .emf, Inkscape changing used objects in image

Bug #715692 reported by Joey on 2011-02-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alvin Penner

Bug Description

Issue 1 (Incomplete):
---------------------
Hey,

I am using 0.47. After drawing I save my image as .svg and .emf. In .svg file everything is fine. But in .emf file the position and geometry of my created objects is changed and this ruin my whole picture... When saving from .svg to .pdf it is also fine...

Have any one any idea?

Issue 2 (Confirmed):
--------------------
I've the same problem reading .emf files: the objects moved and I don't know why. I've installed the 7-zip decruncher in the last inkscape version (Inkscape 0.48.2 r9819). I attach you the figure that I'm trying to import.

(for attachment see comment #10)

Joey (dem0) wrote :
Joey (dem0) wrote :

the .emf file ...

Joey (dem0) wrote :

the .emf file ...

Alvin Penner (apenner) wrote :

the emf export routine was recently changed, in bzr rev 9995, in response to Bug 407394, attached is the file produced using that version.

Does this solve the problem for you?

su_v (suv-lp) wrote :

@Joey - you can test the improved EMF export with a recent development build for Windows, available from <http://inkscape.modevia.com/win32/?C=M;O=D>.

tags: added: emf exporting
Joey (dem0) wrote :

@Alvin: Yeah, this picture looks great - no visibe changes. How do you did it? Is there any Version for a better EMF export?

@suv: I got here some problems to open this file. Probably it get at home better...

su_v (suv-lp) wrote :

@Joey - the URL points to the index page of a directory, with the links to the packages you can download.
The parameters '?C=M;O=D' sort the list by the 'Last modified' date, with the newest at the top.
The most recent available development build for win32 at the moment is r10017, uploaded on 26-Jan-2011.

> I got here some problems to open this file

Possibly your browser (IE?) doesn't understand the '<' and '>' delimiters I used for the URL? Try this one:
 http://inkscape.modevia.com/win32/?C=M;O=D
or (without sorting the entries: look for the file 'inkscape_R10017-1101262125.7z'):
 http://inkscape.modevia.com/win32/

If none of the above links works, possibly a local proxy at your current location blocks the connection.

Alvin Penner (apenner) wrote :

Hi,
   if you've never done this type of Inkscape upgrade before, you may need to install the 7-zip decruncher, available from

http://www.7-zip.org/download.html

Alvin Penner (apenner) wrote :

@Joey - have you had an opportunity to try a more recent build of Inkscape?
- do you need any assistance in updating the Inkscape version?

Changed in inkscape:
status: New → Incomplete

Dear all,

I've the same problem reading .emf files: the objects moved and I don't know why. I've installed the 7-zip decruncher in the last inkscape version (Inkscape 0.48.2 r9819). I attach you the figure that I'm trying to import. Could somebody help me on that?

Thanks beforehand,

Diego

Alvin Penner (apenner) wrote :

this is not related to the original report, which concerned export not import. However, since the original report appears to be idle, I think I'll re-open this bug.

- using file cls1_act.emf the problem is reproduced in Inkscape 0.48.3.1, Windows 7. There is a vertical offset between text and graphics when importing the emf file.

- the problem is not reproduced on Inkscape rev 11499. However there is still some missing border and missing tick marks on this import, see attached svg file.

Changed in inkscape:
status: Incomplete → Confirmed
su_v (suv-lp) wrote :

@Alvin - could you please adapt the bug summary/description to to reflect your change of topic here (confirming an issue about _importing_ whereas the bug report originally was about _exporting_).

<off-topic>"reusing" and confirming an old (incomplete) bug based on a different issue and sample added later in the comments only is confusing (IMHO). We usually recommend to file a separate report (it's really difficult to discover the second but actually confirmed and possibly fixed issue via searching).</off-topic>

tags: added: importing win32
Alvin Penner (apenner) wrote :

sorry about that, I don't think I have the authority to modify the bug description. It used to be that there was a link to allow one to change the description, but that link disappeared somewhere as a result of all the recent changes, so I can no longer find it.

Hi Alvin,

Thanks a lot for your quickly answer. But in the end, what should I do: a)
report a new bug with all the information, b) look for the missing link...
I'm a bit lost because it\s the first time that I'm using Inkscape and
reporting a bug. Sorry for my ingnorance.

Best,

Diego

On 29 June 2012 13:10, Alvin Penner <email address hidden> wrote:

> sorry about that, I don't think I have the authority to modify the bug
> description. It used to be that there was a link to allow one to change
> the description, but that link disappeared somewhere as a result of all
> the recent changes, so I can no longer find it.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/715692
>
> Title:
> When saving as .emf, Inkscape changing used objects in image
>
> Status in Inkscape: A Vector Drawing Tool:
> Confirmed
>
> Bug description:
> Hey,
>
> I am using 0.47. After drawing I save my image as .svg and .emf. In
> .svg file everything is fine. But in .emf file the position and
> geometry of my created objects is changed and this ruin my whole
> picture... When saving from .svg to .pdf it is also fine...
>
> Have any one any idea?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/inkscape/+bug/715692/+subscriptions
>

it would probably be best to file a new bug report,

Alvin

su_v (suv-lp) wrote :

<off-topic>
Alvin wrote:
> sorry about that, I don't think I have the authority to modify the bug
> description. It used to be that there was a link to allow one to change
> the description, but that link disappeared somewhere as a result of all
> the recent changes, so I can no longer find it.

See attached screenshot: if logged in, there are two 'Edit' buttons for the summary and the description. If they are not present for you, this could either be a problem with IE, or Launchpad yet again changed the required priviledges for various parts of individual reports (I'm not keeping up with all the details of changes that continually are applied to launchpad's bug tracker interface).

Could you possibly test with an alternative browser (e.g. Firefox)? If that doesn't help, wouldn't you be interested to join the bug team [1]? You are of such valuable help with bug triage and bug fixing… :)

[1] apply here: <https://launchpad.net/~inkscape.bugs>
</off-topic>

Alvin Penner (apenner) on 2012-06-29
summary: - When saving as .emf, Inkscape changing used objects in image
+ When importing an .emf, Inkscape changing used objects in image
Alvin Penner (apenner) wrote :

<off topic>yes, that worked well, thanks.
I had never tried that button before, I was looking for a button that said 'Edit'.
As you can see, I do not respond well to change, I very much preferred this website the way it was a year ago. I have access to this website on three machines, one Firefox, one IE8 and one IE9, and all three are noticeably different, so I am in a state of constant confusion, and annoyance.
   As to being on the bug team, I appreciate the offer very much, but I'm in the process of attempting to reduce my involvement, would like to do some Java programming instead, would like to work on a cross-platform project, but not C and not VB, which is where I originally came from.</offtopic>

as for this particular bug, will take a look at it sometime next week

su_v (suv-lp) wrote :

@Diego - since bug summary, description and tags have been updated now, I propose to reuse this report for your issue as well (i.e. nothing for you to do at the moment - let's wait and see whether Alvin figures out a fix for the missing borders and tick marks).

description: updated
Changed in inkscape:
importance: Undecided → Medium
Alvin Penner (apenner) wrote :

patch committed to bzr rev 11521,
attached is the resulting svg file

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2012-07-03
Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
milestone: none → 0.49
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers