Filter Effect Turbulence Base frequency limited to 0.400

Bug #713064 reported by ivan louette on 2011-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
jazzynico

Bug Description

Already in 0.46 and not changed, Filters Turbulence base frequency is limited to 0.400 in Filters Editor.

I experimented up to 1.000 without any problem and that's the value I use for grain and noise filter effects. But as for other values limited by the Filters Editor the user could be disappointed being not able to come back to high values after some changes.

0.48 and 0.48 devel rev 10019 on kubuntu 10.04

su_v (suv-lp) on 2011-02-04
tags: added: filters-svg ui
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.47, 0.48.0, 0.48.1 and 0.48+devel r10032 on OS X 10.5.8.

Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed
jazzynico (jazzynico) wrote :

Let's see if it can be improved for 0.49...

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
status: Confirmed → Triaged
jazzynico (jazzynico) wrote :

Changed in the trunk as of revision 10557.

Changed in inkscape:
status: Triaged → Fix Committed
gear (by--3) wrote :

I'm using inkscape 48.4, and noticed this bug is still there... at least in the windows version. I did find a temporary work around by opening the xml editor and finding the filter I was able to enter any value I wanted, but it's a major pain with complex SVG's.

Alvin Penner (apenner) wrote :

this has been fixed in trunk, meaning that it is available in current development versions of Inkscape. For Windows you can get a new development version at:
http://www.oss-marketplace.com/index.php/downloads-mainmenu-63/Inkscape/Entwicklerversionen/

you may need to download and install 7-zip as well, to unzip the files. This is available at :
http://www.7-zip.org/

gear (by--3) wrote :

Hmm... well apparently the color matrix was broken in the past as well. My fault for not double checking my texture in another SVG viewer before approving some matrix adjusted colors. Better to catch it now though! ;)

gear (by--3) wrote :

Ok , it seems the reverse of what I was saying is true. The old inkscape code did the correct thing, and it seems this may be a core bug in the SVG color matrix filter, because a simple test is showing it's incorrect in Firefox, and Chrome as well.

The RGB Float values of .5, .25, .25 are not even close to the correct color. This should result in the same color as we get with the Byte values 127,63,63 else where. Instead of a reddish wine color I get almost a salmon pink.

Looks like the only solution at this point is to use floods to get the correct color, and desaturate to pull my masks to comp with. Makes this filter unnecessarily complicated.

gear (by--3) wrote :

Okay, last update on this. Apparently my old texture filter corupts the color matrix filter in the new version of inkscape, because I started off with a fresh file for a bug report, and now I'm getting correct colors. I load the other version and everything wonks out. not sure the exact cause was. My apologies.

jazzynico (jazzynico) on 2015-02-14
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers