crashes on ctrl-x reproducible bug

Bug #696732 reported by Andrew Fenn on 2011-01-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

Steps to reproduce

open up inkscape
pick circle drawing
create a circle
pick pen tool
draw a line
click node tool
select line and move it
while still on node tool click on circle
press ctrl-x
inkscape crashes

I'm using 0.48 the version that ships with Ubuntu maverick.

su_v (suv-lp) wrote :

reproduced with Inkscape 0.48.0 on OS X 10.5.8
not reproduced with Inkscape 0.48+devel r9994 on OS X 10.5.8

seems to be fixed in trunk - @JazzyNico, can you confirm?

tags: added: crash node-editing
Changed in inkscape:
importance: Undecided → High
status: New → Incomplete
su_v (suv-lp) wrote :

Inkscape 0.48.0 seems to hang in
  sp_event_context_item_handler(SPEventContext*, SPItem*, _GdkEvent*)

(see attached sampling of the hung process of Inkscape 0.48.0)

su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48.0 r9752 (fix seems to have been backported to 0.48.x too).

jazzynico (jazzynico) wrote :

Bug reproduced on Windows XP, Inkscape 0.48, but fixed in the trunk version (can't test the 0.48.x branch now).

Changed in inkscape:
milestone: none → 0.48.1
status: Incomplete → Fix Committed
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers