Make linked offsets respect "Relink duplicated clones" settings

Bug #686193 reported by Adonis Papaderos on 2010-12-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Adonis Papaderos

Bug Description

Please see Bug #239297 for more details.

Changed in inkscape:
status: New → Confirmed
assignee: nobody → Adonis Papaderos (ado-papas)
su_v (suv-lp) on 2010-12-06
Changed in inkscape:
importance: Undecided → Wishlist
tags: added: shape-editing
su_v (suv-lp) wrote :

Patch tested and confirmed with Inkscape 0.48+devel r9941 + diff on OS X 10.5.8

Preferences pane needs to be updated to include 'linked offset' in the description.

Current version:
 When duplicating original+clone:
  [ ] Relink duplicated clones

New version - not sure about what to propose:
"When duplicating original+clone or original+linked offset:" -- too convoluted?
"When duplicating original+clone/linked offset:" -- too technical?

su_v (suv-lp) wrote :

Branch was merged in revision 9944 by Krzysztof Kosinski

Setting status to 'In Progress' because preference pane still needs update (IMHO).
Please set bug status to 'Committed' if you think linked offsets do not need to be explicitly mentioned.

Changed in inkscape:
status: Confirmed → In Progress
Adonis Papaderos (ado-papas) wrote :

@~suv: I vote for the second one, but I am a technically inclined person and not a native English speaker. Could you, please, pick one?

Changed in inkscape:
assignee: Adonis Papaderos (ado-papas) → nobody
jazzynico (jazzynico) wrote :

I vote for the second one too. Unless someone raise an objection, I'm going to commit it later today.

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
jazzynico (jazzynico) wrote :

Fixed in the trunk, revision 10110.
@Adonis, I'm reassigning this report to you because YOU fixed the main issue.
Thanks again!

Changed in inkscape:
assignee: JazzyNico (jazzynico) → Adonis Papaderos (ado-papas)
status: In Progress → Fix Committed
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers