crash while using the top rounding handle

Bug #680520 reported by Dragasani on 2010-11-23
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Adonis Papaderos
inkscape (Ubuntu)
Medium
Unassigned

Bug Description

When I shift-left click the top rounding handle of a rectangle the application crashes systematically. I can do any operation on both handles (dragging, ctrl, right click...) successfully apart from this very specific one.

Dragasani (dragasani) wrote :

I use Inkscape 0.48 and Ubuntu 10.10

su_v (suv-lp) wrote :

Duplicate of Bug #515960 “inkscape crashed with SIGSEGV in KnotHolderEntity::update_knot()”?

tags: added: crash shape-editing
Adonis Papaderos (ado-papas) wrote :

This patch should fix this bug. It removes the update_knot call from RectKnotHolderEntityRX::knot_click. It is not used in RectKnotHolderEntityRX::knot_click either.

Adonis Papaderos (ado-papas) wrote :

*second method name should have been RectKnotHolderEntityRY::knot_click. sorry.

su_v (suv-lp) wrote :

Fix tested and confirmed with Inkscape 0.48+devel r9914 + inkscape-680520.diff on OS X 10.5.8:

Shift+click on the Rx knot now resets both radii for the rounded corners to 0 (instead of crashing), as does Shift+click on the Ry knot.
Ctrl+click on the Rx knot sets Ry to the same value (instead of crashing), as does Ctrl+click on the Ry knot set Rx to the same value (creating symmetrically rounded corners).

No regressions found so far with regard to (not) updating the Rx knot.

Changed in inkscape:
importance: Undecided → High
status: New → In Progress
su_v (suv-lp) wrote :

Still a duplicate of bug #515960

su_v (suv-lp) wrote :

Relevant keyboard shortcuts that triggered the crash (Rx knot):

Ctrl+click set the corner circular
Shift+click remove corner rounding

<http://inkscape.org/doc/keys048.html#id2408385>

Hi Adonis,

Just noticed that Krzysztof has applied five of your patches to trunk. That's much appreciated!

As a consequence though, you can get direct access to our bzr repository to commit your fixes yourself. (At some point in time, way back, the devs agreed on a threshold of two bug fixes for such right)

Just drop a note and we'll get you direct access.

Thanks again,

Changed in inkscape:
milestone: none → 0.48.1
status: In Progress → Fix Committed
jazzynico (jazzynico) wrote :

Committed in the trunk (revision 9921) and in the 0.48.x branch (revision 9734).

su_v (suv-lp) on 2010-12-05
Changed in inkscape:
assignee: nobody → Adonis Papaderos (ado-papas)
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Ubuntu):
importance: Undecided → Medium
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers