page margins can't be reset with single click of Resize

Bug #680347 reported by Brynn on 2010-11-23
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico

Bug Description

Follow-up report to
Bug #499942 "Fit page to selection" needs margin options

Hi Friends,
Page margins can't be set with single click of "Resize page to drawing or selection", IF margins had previously been set or if Resize has previously been clicked. If margins had previously been set, even by default when clicking Resize (without typing margin values) apparently sets them to zero, then to change them, they must be changed one at a time. For example, if I type margin values for each of 4 sides, and click Resize, only one of them retains the value (usually the Top margin). I have to type a value for the Left margin and click Resize, type for right margin and click Resize, and type for bottom margin and click Resize, to have them all reset.

The feature works normally if Resize has not been clicked. As long as values are typed in to each margin before Resize is clicked for the first time, all 4 are set at once.

First reported and confirmed at InkscapeForum.com: http://www.inkscapeforum.com/viewtopic.php?f=29&t=6469
Reported from Windows 7, 64-bit, Inkscape 0.48 stable. Confirmed with 0.48 and 0.48+devel r9916, not sure about confirming os.

Please let me know if more info is needed.
Thank you very much :-)
Brynn

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48.0 and 0.48+devel r9914 on OS X 10.5.8

tags: added: ui
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) wrote :

Once the values for the four margins have been written to the SVG document for later reuse, 'Fit page to…' only takes one changed margin value into account when clicked:

  <sodipodi:namedview
     (…)
     fit-margin-top="40"
     fit-margin-left="15"
     fit-margin-right="15"
     fit-margin-bottom="50">

If those four 'fit-margin' attributes are deleted from the SVG file (using e.g. the XML Editor), the next 'Fit page to contents…' command again sets all four margins with one click.

description: updated
Alex Leone (acleone) on 2010-11-23
Changed in inkscape:
assignee: nobody → Alex Leone (acleone)
dopelover (dopelover) wrote :

Confirmed on Windows XP SP2 and Inkscape 0.48, as well as on Ubuntu 10.10 and Inkscape 0.48+ r10009

Micool (micool-angers) wrote :

was fixed in R-9931

...But is back in R-10001 in a different way : left, right , bottom margin are ignored ...

This bug is the major one for me: I check this in each new build cause I'm using Inkscape daily at work for plannings and schematics...

From now I'm stuck with R-9931...

su_v (suv-lp) wrote :

Works (with limitations as reported) with
Inkscape 0.48+devel r9944 custom, built Dec 9 2010 (OS X 10.5.8 i386)

Fails (only considers top margin) with
Inkscape 0.48+devel r9950 custom, built Dec 12 2010 (OS X 10.5.8 i386)

-> regression was introduced between r9944 and r9950
(possibly by the merge of the C++-ification branch in r9946?)

Changed in inkscape:
importance: Low → Medium
tags: added: regression
DDJJ (jldai) wrote :

similar problem with 0.48.1 stable release in Win 7 64bit. I have to hit "Resize page to drawing or selection" twice to make it.I did not change any values. If you need samples to reproduce the bug, let me know.

su_v (suv-lp) wrote :

- Regression from r9946 (only top-margin used) fixed in r10145
- Issue as originally reported still present ('Resize page to drawing or selection' only updates one changed margin at the time)

(tested with Inkscape 0.48+devel r10145 on OS X 10.5.8 (i386))

Micool (micool-angers) wrote :

I'm wathcing this issue for a long while.
Alex doesn't seem to be an active developper, maybe this should be assigned to s.o. else?

Alex Leone (acleone) on 2011-04-18
Changed in inkscape:
assignee: Alex Leone (acleone) → nobody
Micool (micool-angers) on 2011-05-15
Changed in inkscape:
status: Confirmed → In Progress
status: In Progress → Confirmed
jazzynico (jazzynico) wrote :

Apparently the issue doesn't show when the values are set with the arrows, but only when typed with the keyboard.

jazzynico (jazzynico) on 2011-06-24
Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.48.2
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

Fix committed in the trunk, revision 10355.
Branch tests in progress.

jazzynico (jazzynico) wrote :

Fixed in the branch, revision 9805.

Changed in inkscape:
status: In Progress → Fix Committed
Micool (micool-angers) wrote :

tested on R10350 : solved
great !

thank you jazzynico !

Ted Gould (ted) on 2011-09-07
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers