Inkscape: A Vector Drawing Tool

Some diagrams results in "Illegal character" in the generated pdf

Reported by Damien Cassou on 2010-11-08
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned
cairo (Ubuntu)
Undecided
Unassigned

Bug Description

When I try to generate a pdf from the attached inkscape file, things seem to work properly. However,

- when I open it with evince, I got a lot of "Illegal character <6e> in hex string" (with varying character values) but it opens correctly and I can see everything.

- same thing with pdflatex : the resulting document looks correct but I get a lot of the same error message in the pdflatex output.

- when I open it with acroread, I have an error message and I can't see the diagram. The error message is "There was an error processing the page. There was a problem reading this document (117)."

Inkscape 0.48.0 r9654 on Ubuntu 10.10.

I tried to simplify the inkscape file a bit but each time I try the error messages change or disappear.

Damien Cassou (cassou) wrote :
~suv (suv-lp) wrote :

Attaching PDF file exported with Inkscape 0.48.0 on OS X 10.5.8 (cairo 1.8.10)

Note: Inkscape used the fallback font 'Sans' (Bitstream Vera Sans). I haven't tried to replace the fonts with those I have available under a similar name:

Found the following fonts (Extensions > Text > Replace font):
'Times New Roman,'
DejaVu Sans
DejaVu Sans Bold
Times New Roman
Trebuchet MS
Trebuchet MS Bold

tags: added: exporting
removed: corruption
Damien Cassou (cassou) wrote :

This pdf file does not produce any error message from evince, pdflatex or acroread. What can be the difference? libcairo is 1.10.0 here.

~suv (suv-lp) wrote :

Apple's Preview.app displays the PDF file fine, but complains about:

 encountered unexpected object type: 7.
 missing or invalid object number.

Ghostscript 8.70 and 8.71 fail to render the PDF file:

gs 672686-style-architectural.pdf
GPL Ghostscript 8.71 (2010-02-10)
Copyright (C) 2010 Artifex Software, Inc. All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Processing pages 1 through 1.
Page 1
Error: /rangecheck in --run--
Operand stack:
   --dict:7/16(L)--
Execution stack:
   %interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 1878 1 3 %oparray_pop 1877 1 3 %oparray_pop 1861 1 3 %oparray_pop --nostringval-- --nostringval-- 2 1 1 --nostringval-- %for_pos_int_continue --nostringval-- --nostringval-- false 1 %stopped_push --nostringval-- --nostringval--
Dictionary stack:
   --dict:1153/1684(ro)(G)-- --dict:1/20(G)-- --dict:75/200(L)-- --dict:75/200(L)-- --dict:108/127(ro)(G)-- --dict:288/300(ro)(G)-- --dict:22/25(L)-- --dict:6/8(L)-- --dict:21/40(L)-- --dict:5/5(L)-- --dict:1/1(ro)(G)--
Current allocation mode is local
GPL Ghostscript 8.71: Unrecoverable error, exit code 1
LeWitt:bug suv$

~suv (suv-lp) wrote :

Attaching PDF file exported with Inkscape 0.48+devel r9873 (using Cairo 1.10) on OS X 10.5.8,
exported as PDF 1.5 (see bug #664335).

Damien Cassou (cassou) wrote :

This last file is corrupted:

Error (2603): Illegal character <a4> in hex string
Error (2604): Illegal character <5e> in hex string
Error (2605): Illegal character <40> in hex string
Error (2607): Illegal character <57> in hex string
Error (2608): Illegal character <47> in hex string
Error (2609): Illegal character <8b> in hex string
Error (2610): Illegal character <5b> in hex string
Error (2611): Illegal character <11> in hex string

Damien Cassou (cassou) wrote :

I attach the corrupted pdf file that I created

~suv (suv-lp) on 2010-11-08
Changed in inkscape:
importance: Undecided → Medium
tags: added: cairo

It is a bug in cairo 1.10.0. It has been fixed on the 1.10 branch with this commit

http://cgit.freedesktop.org/cairo/commit/?h=1.10&id=f747ea81fb91239690b1785bce9ed29cb58c9098

and will be in the next stable release of cairo (1.10.2). You will probably have to file a bug with Ubuntu to get them to include the patch.

~suv (suv-lp) wrote :

After flattening the diagram (ungrouping all groups inside layer 1), the 'Illegal character <…> in hex string' errors no longer occur, of the remaining ones from poppler when importing the PDF file in Inkscape:

Error (723): Illegal character '}'
Error (814): Illegal character ')'
Error: ExtGState 's8' is unknown
Error: ExtGState 's11' is unknown
Error (15123): Illegal character '>'
Error: ExtGState 's15' is unknown
Error (723): Illegal character '}'
Error (814): Illegal character ')'
Error: ExtGState 's8' is unknown
Error: ExtGState 's11' is unknown
Error (15123): Illegal character '>'
Error: ExtGState 's15' is unknown

the ExtGState ones are related to the 4 paths with gradients (3 radial, one linear, with Repeat: none).

The errors 'Illegal character <..> in hex string' are triggered by the text

Opérateurs
de contexte

inside 2 nested, transformed groups.

Jeff Kowalczyk (jfkw) wrote :

Just another data point. I am experiencing PDF output that renders gradients improperly on evince (this is not the purpose of posting), and (this is the relevant part) fails to open in Adobe Acrobat Reader 9.4 on Windows: "There was an error processing a page. There was a problem reading this document (109)."

http://thread.gmane.org/gmane.comp.graphics.inkscape.user/13625

The following SVG will reproduce the problem on my system:
http://www.openclipart.org/people/warszawianka/applications-internet.svg

Attached are a screenshot and PDF.

Krzysztof Kosinski (tweenk) wrote :

Problem disappears when using Cairo master, so this is a bug in Cairo.

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Natty Narwhal.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in inkscape:
status: New → Invalid
Changed in cairo (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers