Poor wording in data-loss prompt

Bug #668991 reported by Does it matter? on 2010-10-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

When a new document has been saved in a non-native format and the user subsequently attempts to close it, a prompt warns the user about the loss of data and suggests that they "Save as SVG", even if the format that the document was saved in was an SVG variant.

description: updated
description: updated
su_v (suv-lp) wrote :

Duplicate of Bug #418085 “wrong lossy format warning message”?
<https://bugs.launchpad.net/inkscape/+bug/418085>

tags: added: saving
su_v (suv-lp) wrote :

> and suggests that they "Save as SVG", even if the format
> that the document was saved in was an SVG variant

Choosing a variant of SVG doesn't mean there is no risk of data loss: Formats like 'Plain SVG' and 'Optimized SVG' are seen as lossy formats compared to Inkscape's native format (Inkscape SVG(Z)) because they doesn't support Inkscape-specific extensions and attributes which e.g. allow to keep the document structured into layers, shapes parametrized and path effects editable and live-updating.

Yes, I didn't mean that no SVG variants were lossy, just that since Inkscape supports saving in many SVG formats, only a subset of which are considered lossless, one shouldn't take "SVG" to mean "a lossless format".

The prompt actually gets it mostly right, the body text says "Do you want to save this file as an Inkscape SVG?", but the affirmative button on the prompt is labeled "Save as SVG".

Is this unimportant? Yes, but when the fix would be as simple as relabeling the button "Save as Inkscape SVG", or even "Yes" (though I hear "Yes" buttons are unfashionable these days), it's hardly a waste of time.

su_v (suv-lp) on 2010-10-31
tags: added: ui
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
jazzynico (jazzynico) on 2012-03-05
Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
status: Confirmed → Triaged
jazzynico (jazzynico) wrote :

Committed in the trunk, revision 11048.

Changed in inkscape:
status: Triaged → Fix Committed
jazzynico (jazzynico) on 2015-02-14
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers