Inkscape: A Vector Drawing Tool

Nodes rotation center doesn't snap to grid

Reported by Jihugen on 2010-10-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Krzysztof Kosinski

Bug Description

When rotating a group of nodes, I can't snap the center of rotation to the grid (as it does when working with objects).

To reproduce this bug / missing feature:
- be sure that the "Show transformation handles for selected nodes" option is activated
- select several nodes
- clic on one selected node to display rotation handles instead of scale handles
- drag the cross mark to position the center of rotation --> the cross doesn't snap to the grid.

I'm running Win XP SP3.
I have tried with Inkscape 0.48.0 r9654 (stable version) and inkscape 0.48+devel r9832 (file inkscaper9797-1009282106.7z on the Win32 Snapshots page).

Related branches

Jihugen (jigebren-gen) wrote :
description: updated
~suv (suv-lp) wrote :

reproduced with Inkscape 0.48 and 0.48+devel r9854 on OS X 10.5.8

tags: added: node-editing snapping
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
~suv (suv-lp) wrote :

Not only the rotation center doesn't snap to grid or other snap targets - none of the transformations do either (compared to the transforms with the select tool).

Related to or duplicate of
Bug #590261 “[Node tool] Scale/stretch/skew transforms with transform handles don't snap”:
<https://bugs.launchpad.net/inkscape/+bug/590261>

~suv (suv-lp) on 2010-10-27
summary: - Nodes rotating center doesn't snap on grid
+ Nodes rotation center doesn't snap to grid
Krzysztof Kosinski (tweenk) wrote :

There is a bug with constrained snapping which persists in stable, but is fixed in trunk, it should be reported separately

Changed in inkscape:
milestone: none → 0.48.1
assignee: nobody → Krzysztof Kosinski (tweenk)
status: Confirmed → Fix Committed
~suv (suv-lp) wrote :

trunk: r9960
0.48.x: r9749

~suv (suv-lp) wrote :

@Krzysztof
> There is a bug with constrained snapping which persists in stable,
> (…), it should be reported separately

Can you give me a hint what you are referring to? I have rebuilt trunk (r9962) and the branch (0.48.x r9749); in the branch version, snapping of the rotation center seems to work fine in initial tests (to grid, guides, nodes...), same for constrained dragging in x- or y-direction and constrained rotating of the selected nodes.

jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments